Skip Navigation

[Resolved] Toolset errors

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Waqar 1 month, 4 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#2427041
Screen Shot 2022-07-28 at 10.37.55.jpg

I am trying to: We were following the instructions on this support ticket when it caused the following errors in our staging site: https://toolset.com/forums/topic/organize-custom-posts-not-in-sidebar-with-pins/

Link to a page where the issue can be seen: hidden link

I expected to see: the sidebar pins organized in pages as per the support thread,

Instead, I got: We were making changes to the Toolset post types as mentioned in the support ticket initiated by you: https://toolset.com/forums/topic/organize-custom-posts-not-in-sidebar-with-pins/

It threw some error while saving because of incompatibility with PHP 8. The developer asked the system admin to change the PHP version to 7.4, then it worked fine. However, we still receive the same error as warning while saving the post types in Toolset. This could be a problem in the future. We need to get an idea of how to fix this issue.

Can you please advise us if you need admin access? we are unable to provide you with FTP access.

#2427589

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I've performed some tests on my website with the 'show_in_menu' option, but couldn't reproduce this warning message.

Can you please share temporary admin login details, in reply to this message?
( FTP access is not needed )

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

#2428853

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

PHP 8 compatibility has been included already in the latest release of Toolset plugins:
https://toolset.com/2022/05/toolset-1-6-3-full-compatibility-with-php-8/

In your website's "Conférences" post type settings, no value is set for "Permalink epmask".
( screenshot: hidden link )

By default, it is set to "EP_PERMALINK". Can you please add this in the field and test saving the post type again, in PHP 8?