Skip Navigation

[Resolved] Organize custom posts – not in sidebar with pins

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 2 replies, has 2 voices.

Last updated by michaelP-24 4 months, 1 week ago.

Assigned support staff: Luo Yang.

Author
Posts
#2424763
Screen Shot 2022-07-25 at 4.23.24 PM.png

Tell us what you are trying to do? We migrated from Joomla to WordPress and used Toolset to help. It worked great, but now many of the migrated custom posts are displaying in the backend admin menu displayed as "Pins". Is there any way to move these into a subfolder? The entire left side of our WP admin has dozens of these migrated custom posts. *see the screenshot below. How can I better organize these so the Admin area is not so cluttered?

Is there any documentation that you are following? no

Is there a similar example that we can see? uploaded screenshot

What is the link to your site? hidden link

#2425083

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

show_in_menu.jpg

Hello,

You can customize the position of custom post type in the admin menu, for example:
Dashboard-> Toolset-> Post types, find and edit your custom post type, in section "Options", change the option "show_in_menu" value to: edit.php?post_type=page
It will display your custom post type under "Page" menu
See my screenshot show_in_menu.jpg

More help:
https://developer.wordpress.org/reference/functions/register_post_type/#show_in_menu
show_in_menu
(boolean or string) (optional) Where to show the post type in the admin menu

#2425539

My issue is resolved now. Thank you!