Skip Navigation

[Resolved] Content Template and Ultimate Addons for Gutenberg

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by davidM-17 1 month, 1 week ago.

Assigned support staff: Minesh.

Author
Posts
#1781247

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi David,

I've updated the plugins on the previous test site your shared and I can see now social icon and table of content block is displayed as added in the backend in the content template.

This is how the social share and table of content is added in the backend: hidden link
This is how its displyed on the frontend => hidden link

I can see the same with "FAQ Schema bloc" block. Its working as well (using Content Template created using block):
This is how its added at backend: hidden link
This is how its displayed on frontend: hidden link

If you want to see the different and how its fixed. You can download and install the following duplicator package:
=> hidden link

**Admin Access: **
Toolset / (wr7lyD%*#DSIabyhJFxcu2a

CT where user added the social share block that belongs to UAG and this CT is set to display with default post post-type:
=> hidden link

If you visit the following post on frontend - the icon are not displayed as expected.
=> hidden link

First check the "/another-blog-post/" after installing the duplicator plugin, then you should update all Toolset plugins + UAG plugin and then again load the post "/another-blog-post/" and notice the difference.

if you have any other issue please let me know.

#1783273

Hi Minesh,

I tried this out on a new site and it worked fine. As you showed, the Table of Contents doesn't actually work, but it has the styling and I don't think that it not picking up the headings is a Toolset issue, but more that it can't pick them up when included in a CT.

I figured out the problem I was having. I had put all of the blocks in a Toolset Container block and it had some weirdness. If you are interested in trying to replicate, in a new CT for posts I added a Toolset container block, inside of that a single field set to the post content, and at the bottom the UAG FAQ block. It was weird in the CT editor and on the front that the FAQ has the style but it was kind of half in / half out of the container. I deleted the Toolset container and recreated the CT without it and it worked fine.

Thank you for your help in getting this fixed. For me, I'm considering it done, but I wonder what should be the expectation going forward with other Gutenberg addons? Is there a guide or something?

Best regards,

David

#1783723

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi David,

Great and Glad to know that it woks as expected.

Here is the Doc you can follow to know what Block plugins are compatible with Toolset:
=> https://toolset.com/documentation/beyond-pages-program/block-plugins-compatible-with-toolset/

Please feel free to mark resolve this ticket.

#1784189

I'm glad the team was able to fix this. Thank you.