Skip Navigation

[Closed] Views not detecting post relationships

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

Author
Posts
#2643437
Screenshot 2023-09-12 140517.jpg

I'm trying to connect two custom post types, Recipes and Products, so that I can display certain recipes on each product page. I have it set up and working in a dev site, but it isn't working when I move it to the live site. I keep getting this message:

"This will filter out posts of the following types, because they are not related to any other post type: Recipes"

But I have made the relationship, as seen in the screenshot. I did it a second time as well. I also set up a connection between Pages and Posts, and trying to create a view for either of those gives the same error message.

#2643681

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi there

I think to be able to check what's happening, at a minimum we'd need to be able to access your site. Would that be possible? It may also be necessary to take a copy of the site to do some proper debugging of the issue if we can't spot what the problem is on your install, if that would be okay.

Let me mark your next reply as private so that we can get log-in credentials from you—you may want to create a temporary admin user for us to use that you can later delete. And be sure to have a current backup of your site.

Can you also confirm where you are seeing the error? Is it editing a View (which View) in the legacy editor, or editing a View block on a page (which page)?

#2644197

Thanks for your reply! I am working on getting permission to share access to the site. I should be able to get back to you tomorrow.

The error is while editing a View in the legacy Toolset Views plugin. Is the issue probably that we're using the old plugin? That would make sense. I've tried switching to the newer one a few times but I just prefer the old one still.

#2644317

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for sharing this update.

We'll wait for the details that Nigel requested in the last message and I'm setting your next reply as private.

regards,
Waqar

The topic ‘[Closed] Views not detecting post relationships’ is closed to new replies.