Skip Navigation

[Resolved] Views displays empty loop for event calendar

This support ticket is created 4 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 26 replies, has 2 voices.

Last updated by Luo Yang 3 years, 9 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1179467

I am trying to: display content from Modern Tribe's Events Calendar using a View (one on the homepage and another in pages with a sidebar)

Link to a page where the issue can be seen: hidden link (scroll until you see CISO Executive Forum

I expected to see: content displayed by the View

Instead, I got: No Upcoming CISO Forums found

Please note that the front end of the website is currently password-protected so I am not able to provide login credentials through the form.

#1179731

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I have enabled the private message box, please provide your website credentials, I need to check it in a live website, thanks

#1180584

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can login into your website and see the problem, you are right, the post view should be able to output one latest event post in front-end, there isn't any special filter in below view's setting:
hidden link

So the problem is abnormal, I have tried to check the problem page in admin side:
hidden link
I can not edit the content, it display an error message:
This block contains unexpected or invalid content.

So can not see how do you put the Views shortcode [wpv-view] into content.

I suggest you check these:
1) In case it is a compatibility problem, please deactivate other plugins, and switch to wordpress default theme 2019, and test again

2) If the problem still persists, please provide database dump file(ZIP file) of your website, also point out the problem page URL and view URL, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1181195

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

about-issa.JPG
home.JPG

Thanks for the details, I can import your database files, here are what I found:
The post view in both page works fine, see screenshot home.JPG and about-issa.JPG

And I am using a fresh wordpress installation + the latest version of Toolset plugins, so it should be a compatibility problem/server problem of your website,

I have checked it in your website again, you are using 3 "Must-Use" plugins + "Drop-ins" plugin, for example:
advanced-cache.php

I suggest you disable those plugins and clear the website cache and test again.

#1181270

Hi Luo

Thanks for all your help.

I can see, as you say, that the loops are showing up on the fresh WP installation.

I disabled the plugins, as advised, cleared the cache and refreshed the page. But no change.

Then I remembered that I have another View loop on the website (Journal in the sidebar) that displays as it should.

So I decided to play around a little bit.

I tried using just raw text - first in the loop item and then in the view loop (before, after, and in between) - instead of using Views fields and custom fields.

Nothing displayed, so it looked like the loop was "broken."

I created a new loop, same problem.

I started thinking that the issue might be some kind of an issue between Views, Events Calendar plugin, and WP Engine hosting environment (or plugins, as you pointed out).

So I just tried something kind of random and selected a second post type (in this case pages), set the filter to the category I wanted, refreshed the page, and saw the correct output.

Although it's working, this is obviously not a solution.

Anyway, feel free to log back in and take a look.

#1181304

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Yes, I agree, it might be a server problem, please backup your website first, then update this thread, I can try to debug it in your website.

#1181762

Backup has been done, so you're good to go.

#1182001

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have tried the SFTP access, it does not work, I get these error message:
Command: open "issa-toolset@iss****.sftp.wpengine.com" 22
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

Please check it, make sure it is valid, please also PHP debug logs:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/#php-debugging

#1182016

I just tried the credentials I provided and they worked. Looking at the error message above, it looks like you're using port 22. It should be 2222.

For some reason I was unable to generate the error log file using the instructions on the page you linked to.

Not sure if it provides the same information or not, but I did generate an error file using WP Engine dashboard.

Let me know how you would like me to share the file with you.

#1182023

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks, it is port 2222, but I still get these error:
Command: open "issa-toolset@issa***.wpengine.com" 2222
Command: Trust new Hostkey: Once
Command: Pass: ***************
Error: Authentication failed.
Error: Critical error: Could not connect to server

Please check it, it seems the the username/password is not valid, you can update it here:
https://toolset.com/forums/topic/views-displays-empty-loop-for-event-calendar/#post-1180188

And the PHP debug logs is helpful to debug the such kind of problem, please provide it too.

#1184360

Hi Luo

I just realized I sent an incorrect SFTP username, so I have updated the private message with the correct one.

I also uploaded the WP Engine error log to a previous private message.

Thanks again for your help.

#1184805

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Now the SFTP access works, where I can see the problem: no item found?

I have tested both pages in your website:
hidden link
hidden link

There isn't the same problem anymore, if you still need assistance for it, please point the problem URLs, where I can see the same problem:
Views displays empty loop for event calendar

Thanks

#1184817

That's because of the workaround I stumbled onto (select another post type, in addition to Events). In this case, I added Pages as well as Events to the Loop and set the filter to CISO Executive Forum.

Anyway, I have deselected Pages so the problem is evident again on the homepage and any page with a sidebar:

hidden link

hidden link

Also I did notice in the error logs a database error having to do with Events.

#1184822

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

home-2.JPG

I have tried it again, see screenshots home-2.JPG, the problem is not evident again on the homepage.

I am trying to help you to debug this problem, but there isn't same problem in your website, can you describe detail steps to see the problem?
How and where do you "deselected Pages"?

Thanks

#1184838
Sidebar CISO Forum with additional post type selected.PNG
Homepage CISO Forum with additional post type selected.PNG
CISO Executive Forum View with addtitional post type selected.PNG
Sidebar no CISO Events Found.PNG
Homepage no CISO Events Found.PNG
CISO Executive Forum View.PNG

Hi Luo

The screenshot you have shared (home-2.jpg) demonstrates the problem.

The lefthand column - CISO Executive Forum - is supposed to output a CISO Executive Forum loop.

Instead, it's outputting "No CISO Upcoming CISO Forums found."

There is definitely an upcoming forum"

hidden link

Same thing with the sidebar (I have included screenshots from the installation I am working on).

I select/deselect Pages (or any other post type) under Content Selection in the corresponding View).

See screenshot of View with just Events selected.

If I select an additional post type under Content Selection, then both View work (I've uploaded screenshots with Pages also selected under Content Selection in the View and you can see the correct output).

The Views in question can be found using the links I provided previously.

For what it's worth, it doesn't seem to matter what additional post type is selected.