Skip Navigation

[Resolved] View bug and "processing server request, please wait …" infinite

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by stephaneM-4 1 month, 2 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#1719585

Hello,

This ticket is a bug after this support :
https://toolset.com/forums/topic/create-view-in-view-alternative/

I have a problem with the view display. Sometimes it shows up and sometimes it doesn't. In addition, the edition of the templat is very slow.

Each time I get the message "processing server request, please wait ..." non stop ...
hidden link

Can you disable this process when editing the template?

I gave you the access. These are the same as those sent.

hidden link I can no longer display comments with your view and display them.

It worked at first but I have the impression that since importing a larger quantity it no longer appears.

Sometimes I had to save multiple times for it to work. But now I can't display it at all.

Thank you

#1720407

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi St├ęphane,

Thank you for contacting us and sorry to learn about the issue with the nested view.

The main challenge here is that the blocks based views don't support the nested views, as we discussed in the other ticket. Whenever nested views are involved, our recommendation is to use the views created using the classic editor.

I tried to access the admin area, but it seems that the default admin login link has been changed on your website. I'm setting your next reply as private so that you can share the admin login link too.

Do I also have your permission to download a clone/snapshot of your website?
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

This will help in investigating the issue on a different server, without affecting the actual website.

regards,
Waqar

#1724673
#1728331

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi St├ęphane,

Thank you for sharing the admin access.

After testing a couple of different approaches, this is the solution that works without any consistency issues.

Instead of processing the view's shortcode "[wpv-view name="view-to-show-les-avis-related-to-entreprises" wpvrelatedto="[wpv-post-id]"]" inside the content template for single "Villes" post, I registered a custom shortcode and that processes the same and returns it output:
( shortcodes within shortcodes are not very well supported in blocks/Gutenberg editor )


add_shortcode('call_related_LesAvis', 'call_related_LesAvis_func');
function call_related_LesAvis_func() { 
	$post_id = do_shortcode('[wpv-post-id]');
	$output = do_shortcode('[wpv-view name="view-to-show-les-avis-related-to-entreprises" wpvrelatedto="'.$post_id.'"]');

	ob_start();
	echo $output;
	return ob_get_clean();
}

Note: You'll find it added through Toolset's custom code feature at WP Admin -> Toolset -> Settings -> Custom Code.
( ref: https://toolset.com/documentation/adding-custom-code/using-toolset-to-add-custom-code/ ).

After that, I've inserted this newly registered shortcode in the content template for the single "Villes" post and it keeps working, without any interruptions.
( screenshot: hidden link )

As for the "processing server request, please wait ..." message, it is showing in abnormal frequency on your website, when the content template edit screen is open.

To troubleshoot this behavior, you can test it with all non-Toolset plugins disabled and a default theme like Twenty Twenty.

If it's fixed, you can start adding the disabled items, one-by-one, to narrow down to a possible conflicting item.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1733571

My issue is resolved now. Thank you!

Many thanks to you it seems to be working perfectly! I'm really very happy with your support. I also have 2 friends who bought toolset.

Thanks again