[Resolved] updating fileds of CPT in 1:many relationship

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#1625315

Tell us what you are trying to do?

I have CPT 1 MainF : many SubF

All Fields in their custom filed Groups are REQUIRED.

1/ If I modify fields in SubF Group, the following sequence works if the new field is REQUIRED or NOT REQUIRED:
I remove relationship, update SubF Group (add/modify the field), re-create relationship, update existing items of SubF.

2a/ If I modify fields in MainF:
I remove relationship, add FIELD NOT REQUIRED into MainF Group, REMAIN without relationship,
update existing item or add new item of MainF - no problem;

2b/ If I modify field in MainF - add a REQUIRED into MainF Group I GET A PROBLEM: SubF fields remain there permanently:

Sequence: I remove relationship, add REQUIRED field into MainF Group (REMAIN without any relationship),

I try to update EXISTING item of MainF - I see SubF: three out of four empty fields
- I cannot save MainF because I must add a new SubF.

I REMOVE REQUIRED CONDITION from that new field in MainF - I still see SubF: three out of four empty fields
- I cannot save MainF and I must add a new SubF.

In other words:

a/ HOW CAN I CLEAR THAT REQUIRED relationship issue and remove it -
if the solution is a SQL command via phpAdmin, I would very much appreciate it

b/ What I am doing sound like one MUST CREATE A FINAL VERSION OF the CPT Group 1: many CPT's- must not change that "parent CPT".

c/ Because I have two relationships "1: many" I have an issue as I cannot experiment and develop without that cleanup.
`
Many thanks and can you help urgently please?
Peter Lom

Is there any documentation that you are following?
many but this is not described anywhere

Is there a similar example that we can see?
no

What is the link to your site?
dev1.aidxchange.org - I am happy to share screen and/or provide admin privilege

#1625657

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Peter,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot and reproduce this behavior on a test website, I'll need to see exactly how these custom post types, fields groups, and the relationship are set up on your website.

Can you please share temporary admin login details, in reply to this message?

I'll be in a better position to understand the issue and guide you accordingly.

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

regards,
Waqar

#1626579

I tried a brand new - completely separate CPTs with absolutely no relations:
newMainForum, and newSUBForums.

When I try to add item into "newMainForums", SubFS fields appear there again and I simply cannot save even when I used all NON required fields in newMainForums.

I don't want to create an entry form for these CPT's because ultimately I'll populate them all via API.

Please help me urgently.
Thank you

#1626629

Please help me -asap - Waqar does not work on Saturday and I desperately need help.

#1626709

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Peter,

Thank you for sharing these details.

Saturday and Sunday are my off-days, but I'm going to help you out with this particular issue, due to the urgency.

I'm currently reviewing all these details that you've shared and will update you shortly.

regards,
Waqar

#1626711

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

The website that you've shared is showing "This site can’t be reached" message.

If an online website is not ready to share or it is difficult to make it accessible, a quick video/screencast of the steps that you're taking can also make it more clear.

Your next reply will be private and I'll wait to hear back from you.

#1626755

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the updated details.

I noticed that in settings for "Field Group for MainFs", the "MainFs" post type is selected ( screenshot: hidden link ).

However, in the "Field Group for SubFS" settings, it is not restricted to be available on a specific post type ( screenshot: hidden link ).

This means that this field group will be available on post edit screens of all post types.

If this is intentional, I'd like to have more details about the main goal or project's requirement.

regards,
Waqar

#1626795

Thank you again for working on this today!!!
Regret but this did not work (I tried off course your solution it in the past multiple times).

I set now again Field Group for MainFs with post type=MainFs ;
Field Group for SubFS with post type=SubFS ;

Add new MainFS shows these fields:

SubFS ID*
Descripiton SubFS*
Link*
junkFieldSUB*
MainF Description*
Category ID*
Link Main*
junk Main

#1626797

My issue is resolved now. Thank you!