Skip Navigation

[Resolved] Toolset WooCommerce Blocks affecting WP Astra sticky add to cart

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 16 replies, has 2 voices.

Last updated by dbarber 1 year, 8 months ago.

Assisted by: Waqar.

Author
Posts
#2454435

I am trying to: use WP Astra's sticky "add to cart" option.

Link to a page where the issue can be seen: hidden link

You could also look at any product page that's not Zestami (please note that the above URL is from the staging environment).

I used Toolset to build custom WooCommerce product pages and archives and recently discovered a problem.

No matter which product page I'm on, Astra's sticky Add to Cart option grabs the right product name and price, but the wrong featured image (it's always the featured image for the product Zestami) and, when you use the Add to Cart button in the sticky bar, it always adds Zestami to the cart rather than the product from the page you're on.

The option for sticky Add to Cart is found here: Customizer > WooCommerce > Sticky Add to Cart (at the bottom of the Customizer panel)

Even though I suspected the problem comes from the product page customization, I did contact Astra support. After looking into things, they advised me to contact Toolset support.

#2455143

Hi,

Thank you for contacting us and I'd be happy to assist.

Have you tested the sticky Add to Cart without Toolset content template? If not I'll recommend temporarily unassigning the 'WooCommerce Single Product' template from the single product pages, or even better, testing with all Toolset plugins deactivated.

If the issue persists without Toolset plugins, it would mean the Toolset's content template does not cause it. You can report this to Astra's support, showing them the issue with the minimal setup (i.e. without any extra themes or plugins).

If the issue is only experienced when using the Toolset's content template, please let me know and I'll download your website's clone with your permission and have it investigated further.

I hope this helps and let me know how it goes.

regards,
Waqar

#2455695

Sorry, Waqar, I should have said that the reason I'm saying Toolset WooCommerce Block is the cause of the problem is because when I deactivate it, the sticky CTA behaves as it should.

#2456131

Thanks for confirming that.

Do I have your permission to download the website's clone and troubleshoot this on a different server?

#2456429

Yes, Waqar, please go ahead.

Thanks

Dawson

#2457113

Thank you for the permission.

I've created your website's clone at ( hidden link ), but, I'm no longer seeing the issue of the incorrect featured image, on either your website or its clone.

Can you please confirm the same and have you made any changes to fix this?

#2457469

I just checked the staging environment and the sticky CTA is working but that's because Toolset WooCommerce Blocks was deactivated.

I just reactivated it on the staging site and the sticky CTA problem has returned:

hidden link

I took at look at the clone you referenced and it looks like Toolset WooCommerce Blocks is not active.

#2458369

Thank you for clearing this further and I apologize for missing that the "Toolset WooCommerce Blocks" plugin was deactivated.

While the issue is reproducible on your website and its clone, I'm not able to reproduce this on a clean test website.

I'm still working on this troubleshooting and will share my findings, as soon as I'm able to narrow down the exact cause.

#2458507

Thanks for the update, Waqar, and for your help with this!

#2460911

Just wanted to update you that, I'm still working on this and will share the details, as soon as I can.

#2461069

No worries, Waqar. Thanks for keeping me posted.

#2461861

I had some busy forum queue after the weekend, but I'll resume work on this today.

I'll be able to share a detailed update, within the next few hours.

#2462439

No worries. Thank you for keeping me posted.

#2464721

Thank you for waiting. I've found the reason for the sticky add-to-cart feature's incorrect behavior.

In the widget area "Footer Builder Widget 1", the website is using a view named "Single Product Related Posts". This view itself is created using the classic editor, but its loop item template is set to use the blocks editor.

We don't officially recommend/support using the blocks editor template and views in the new blocks-based widget editor, as it can result in unexpected behavior. In this case, for any product that this view shows last, the sticky add-to-cart feature also uses that product's information for the featured image and the add-to-cart link.

To overcome this, you can follow these steps:

1. Please use the classic/legacy editor and not the blocks editor for the loop item template in the "Single Product Related Posts" view.
(and same for any other view that you plan to use in the widget sections)

2. You can then replace the view block with the "Shortcode" block in the widget area "Footer Builder Widget 1", to call the view "Single Product Related Posts":


[wpv-view name="single-product-related-posts" cached="off"]

I hope this helps and please let me know if you need any further assistance around this.

#2466039

HI Waqar

Thanks for your persistence with this issue.

I did as advised but there was no change, then I remembered I was also running a loop in the flyout panel so I replaced it.

Same result (no change).

Eventually I just replaced the Views loop with default WooCommerce and it worked as expected.

I'm not sure if I should close this ticket or not - because the issue doesn't appear to have been resolved - so I'll leave it up to you.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.