[Resolved] Toolset updates do not show up on multisite (no Commercial tab)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Luo Yang 3 years, 5 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#433753

I am trying to: Routinely keep our Toolset plugins up to date

I visited this URL: Related network admin pages

I expected to see: I understand there should be a "Commercial" tab under Plugins > Add New, and possibly a related tab under plugin updates. (See screenshot of Add New window, attached.)

Please see my initial query here:

https://toolset.com/forums/topic/custom-field-condition-parsed-incorrectly/#post-394356

and followup query here:

https://toolset.com/forums/topic/access-appears-to-be-working-globally-vs-by-cpt-wpengine-host/#post-421575

I'd like us to get this issue resolved, please. I would assume it's a multisite issue, but we haven't pursued it sufficiently to get any clarity on it.

Regards,

Jim P.

#433979

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Jim,

I just tested it in your discover-wp.com, which is also a multi-site wordpress installation, and it works fine, the "Commercial" tab does show, see screenshot 2.jpg, so it should not be a problem of multi-site wordpress installation, I suggest you check this:
deactivate other plugins and switch to wordpress default theme, and test again

#434137

Sorry, let's get into this deeper, as your diagnostic solution is not possible on our end; if it were, I would have tried it already, as this is the default diagnostic solution to basically any plugin bug anyone has ever experienced.

Please clarify: on discover-wp.com, are Toolset plugins network activated? (I'd assume so.) They are not network activated on our multisite, which may be the crucial difference.

I attach screenshots from one of our sites where Toolset plugins are activated, including the Plugins view, then the Toolset Settings > Installer screen. On this site, I attempted to update the plugins, and as you can see was unsuccessful...of course, no site admin is allowed to update plugins on a multisite, as that's done via network admin.

I'm happy to pursue this further to help diagnose, but I suspect that your setup does not yet allow for automatically updating Toolset plugins in a multisite configuration where Toolset is not network activated. Very few of our sites use Toolset (though it plays a crucial role on those sites!), and we do not want to confuse all admins by activating Toolset on all sites.

Regards,

Jim P.

#434312

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, Toolset plugins network activated on discover-wp.com, and you are right, it does not allow for automatically updating Toolset plugins.

And I tested a multi-site wordpress installation in my localhost, I can not find the "Commercial" tab too, so there isn't such a feature within Types plugin, if you agree, we can take it as a feature request. our developers will take care of it.

#434321

Yes, please, if you could log it as a feature request we'd very much appreciate...thanks.

Jim P.

#434349

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

OK, I have change this thread's Topic type to "Requests", and reassign it to our developer.

#435158

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Here is the feedback from our developers:
On a multisite, you will need to network activated the Types plugin, Types provides the Commercial tab for plugins and lets you update them.

#437213

Your developer feedback doesn't clarify whether or not they will add this functionality as a Request in future. We are not planning to network activate Types, as many of our users do not need Toolset plugins. Does this mean that the developers do not plan to fix this issue in a multisite environment such as ours?

Jim P.

#437518

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I contact our developers, here is the feedback:

For this problem:
On a mutisite with Types not network activated, Types does not provide the Commercial tab for plugins, hence you can not either update them.

I would call this a bug, inconsistency or usability problem. The fact that it does not work on a specific situation does not mean that "Types does not provide that feature", it means that it is not working on that specific situation.

So I escalated this thread to our 2rd supporters, hope there will be any fix for this problem.

#437708

Okay, many thanks for your assistance, and please keep in touch re. possible fixes...Jim P.

#442890

I have just tested network-activating Types on our multisite, and we still cannot readily update Toolset plugins...see attached screenshot for similar error when attempting to update via Installer or via Plugins. This means that the recommended solution of network-activating Types does not seem to work on a multisite, possibly.

Jim P.

#446485

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Sorry for the delay answer, here is the feedback from our 2nd supporters:
No types plugin active == no commercial Tab == no updates == no registering.
neither on MS, nor on single site.

And here is the feedback from our main developers of the Installer:
This is by design, Installer is currently embedded only to WPML and Types plugins

For the new question:
hidden link
The screenshot you mentioned above, there should be a PHP error occurs, I suggest you create new ticket for it. thanks

#446767

Okay, will keep this ticket open, but create a new one for possible PHP errors...Jim P.

#447279

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

OK, please update this thread if you need more assistance.

#448577

I'm still working on a separate thread; we can close this one as the other is active.