Skip Navigation

[Resolved] Toolset map I cant see the maps.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by antonioC-13 1 month, 3 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#2427939

Hello, I have a problem when putting the map with toolset. I have read the information and the steps to do everything but it doesn't work.
I have tried configuring the google maps api key by web but the toolset does not allow me. I have tried it with the ip of my server but it gives me an error. If I put it without any restriction, yes it lets me access but then I have problems with the Dynamic source of the map, since it stays blank and I can't see it. It is also giving me an error that does not allow me to save the post. I need help. Thank you.
hidden link

#2428513

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see the settings of your website in the admin area.

Can you please share temporary admin login details, in reply to this message?

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

#2429599

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the admin access.

When I check the map settings at WP Admin -> Toolset -> Settings -> Maps, the map loading and API key seems to be functioning correctly.

Also, the post type and the content template that was shown in your video, are also no longer available on the website. I only see the custom post type "Empresas" that is showing the map correctly on the single post pages, through the "Dirección" address type field.
( example screenshot: hidden link )

Have you made any changes to the structure and the post types of the website?

As for adding the restriction to the Google Maps API key, there is some important information that needs to be considered.

If you'll go to WP Admin -> Toolset -> Settings -> Maps, you'll see that there are two fields to enter Google Map API keys.

When only the main/primary key is added, it is used for both the client-side and the server-side requests.

The key with domain restriction works for the client-side requests, but not for the server-side ones. To overcome this limitation, the second optional key field was introduced.

When you'll include a second optional key, that will be used for the server-side requests, allowing you to use a primary key with the domain restriction turned on.

If your hosting server has a static IP, you can optionally enable IP restrictions on the second key too, but it is not necessary, since this second key for the server-side requests is not publically exposed.

I hope this explanation helps and please let me know if you need any further assistance.

#2429633
Captura de pantalla 2022-08-02 a las 16.37.45.jpg

Hello, thank you very much for all the effort.
I have been making changes this weekend on the web, since I have to finish it in a few days. I still have the problem. Right now you see the maps because I have the api without any restrictions. I am attaching a screenshot of the configuration.
reading what you have put me:
"When you'll include a second optional key, that will be used for the server-side requests, allowing you to use a primary key with the domain restriction turned on.

If your hosting server has a static IP, you can optionally enable IP restrictions on the second key too, but it is not necessary, since this second key for the server-side requests is not publicly exposed".

I find what you say interesting, but I don't know how to generate this second key. Where is it generated? My server has a static IP. My fear is that since I have the configuration now I will have a problem. Does something happen if I leave the configuration like this (I leave a screenshot, I'm sorry but it's in Spanish)? Why does it give me an error if I leave the ip configuration? How can I generate the second key or where do I have to go? Thank you very much.

#2430361

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for writing back.

The following steps will make this more clear:

1. As per your screenshot, your current Google Maps API key has the API restrictions set, but no application restrictions.

You can keep this key's settings as it is and go to your website's Toolset Maps Settings and cut the key from the first key's field and paste it into the second optional API key field.

2. Next, go to the credentials section in your Google cloud dashboard ( hidden link ) and create a new API key.

You can set it the same way as the previous key, except that you'll include the HTTP referrer restriction in this key so that it can be used only be used on your website and no one else can misuse it.
( example screenshot: hidden link )

Once this new API key is generated, you'll paste it into the first API key field on your website's Toolset Maps Settings.

#2430479
Captura de pantalla 2022-08-03 a las 16.25.06.jpg

Hello!!

Thanks so much for the explanation. Now it works!! I am very happy and grateful for your help.
Now I have another problem. I have followed the steps so that the search engine does not show any results. I referred to this:
"Hide search results until first search"
I do all the steps as in the tutorial but the results still appear. The code is ok? I put this code:
( ( '[wpv-search-term param='wpv_view_count']' ne '' ) )
But there is no sale.
I attach a screenshot of the message that I get in the right bar.
I don't know what can be done.
Thanks again.

New threads created by Waqar and linked to this one are listed below:

https://toolset.com/forums/topic/split-hide-search-results-until-first-search/

#2431177

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad that I was able to help.

I've created a separate ticket for your question about hiding the search results until the first search and will follow up on it shortly.
( ref: https://toolset.com/forums/topic/split-hide-search-results-until-first-search/ )

You're welcome to mark this ticket as resolved and start a new one for each new question or concern.

#2431249

My issue is resolved now. Thank you!