Skip Navigation

[Resolved] Taxonomy and Custom Field links not working

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 2 replies, has 2 voices.

Last updated by Waqar 9 months, 3 weeks ago.

Assisted by: Waqar.

Author
Posts
#2648943
Screenshot 2023-09-30 113802.png

Tell us what you are trying to do?
On my view loop results pages (hidden link), and on my custom post type templates (hidden link), I have selected "Link to term archive page", but none of the fields are clickable. Obviously that's one of the core functionalities, but I don't know what is causing it to not work as it ought to.

Is there any documentation that you are following?
Basic how to use course

Is there a similar example that we can see?

What is the link to your site?

#2649145

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how this taxonomy and the relevant blocks are set up in the admin area.

Can you please share the temporary admin login details, in reply to this message?

Note: Your next reply will be private and it is recommended to make a complete backup copy before sharing the access details.

regards,
Waqar

#2649613

Thank you for sharing the access details.

I noticed that the 'Heading' block was being used to generate these term archive links, which currently doesn't work. We have an internal ticket to improve this in future releases and I've added your voice to this matter too.

For now, you can replace those 'Heading' blocks with the 'Single Field' blocks which will work just fine to generate the term archive links.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.