Skip Navigation

[Resolved] Split: View settings don't persist

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 50 replies, has 2 voices.

Last updated by Nigel 1 year, 5 months ago.

Assigned support staff: Nigel.

Author
Posts
#2055525

The Hosting provider service has come back!

#2055955

Hi Nigel,
I don't know if that could be true, but I think that there are some conflicts between Toolset and WordPress Multisite.
Well, I had a site, santimartiriotranto.it that has Toolset Type installed on it. The site was installed in his own folder inside the inonda.tv hosting link the staging.otrantoporto.com.
So, because the Files Usage goes up to 57% tonight I have moved the single site into a subsite into the inonda.tv WordPress Multisite like portodiotranto.com.
Now, the File Usage goes a little bit down because there are not the files and folders of a separate WordPress installation, and it is positive.
But, I see that the Physical Memory Usage goes up from 750MB/950MB to 1100MB/1400MB, and I think that there is a critical issue with WordPress Multisite installation because the only things I have done is to move the site from single-site installation to multisite inside the same hosting/server.

#2056203

Hi Nigel,
well, the Physical Memory Usage has come back normal.
I have written to the Host service, and they have done a soft kill of all processes, and they have told me that there were some loops not killed...
After the soft kill, the Physical Memory Usage now is from 500MB to 750MB, and I think that the loops were there before the last Toolset update generated by the Blocks Views issue.

#2058273

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Screenshot 2021-05-17 at 13.47.28.png

I'm trying again this morning but the server appears to have permissions problems affecting REST API requests, which I think you will need to discuss with your host to understand.

I was seeing 403 errors on requests in the browser console when trying to edit the Content Template (this after disabling all plugins except for Types and Blocks, plus you have a drop-in and a must-use plugin which I cannot disable).

So I disabled Toolset altogether, and edited a normal post (the articolo ”Otranto è OTRANTO”).

Even without any plugins active, and with the twentytwentyone theme active, the console is full of 403 errors for the REST API requests that WordPress uses for the Gutenberg editor. See the screenshot.

That's not an environment where I can usefully perform any tests. Could you please resolve that with your hosting company, and then I can continue to investigate.

Thanks.

#2058639
otranto.png

Hi Nigel,
I have written to the hosting support.
I have given them the credentials to enter in the dashboard and I have given to them the link to access in the article to investigate.
They return me the message that they don't have found any issue (see the screenshot), and they have asked me what others steps they can do to replicate the issue.
What can I tell to him?

#2059379

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

2058639-otranto.png

After your reply I went back to try again, and it seemed to be working okay, but the problem quickly reappeared.

I tried again this morning just now, and the problem is still there, namely the 403 responses for many of the requests made to the REST API when editing a post with the Gutenberg editor (this is still with all plugins including Toolset disabled, except for the drop-in and must-use plugins which I cannot disable).

That screenshot the hosting company shared with you doesn't look very useful.

They appear to be checking "doc" network requests only, I don't know why they would be doing that, they need to be checking the XHR requests to see the problem.

I'm sorry about this, I know it must be very frustrating, but while there are such problems on the server the testing I'm able to do is severely limited.

#2059613

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

I've migrated your site to cloudways (a 3rd-party server we use for hosting test sites publicly), and I'll do some debugging work there to see what I can find...

#2059753

Hi Nigel,
Thank you.
I'm waiting for a reply from my hosting service.

#2059865

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Screenshot 2021-05-18 at 14.07.59.png

I've been testing the site for some time (on the cloudways server) and it is working as expected.

I am able to edit the Content Template, select the View Loop block, and then change the Loop Template settings to update the link href, save the template, leave and then navigate back to edit the template again, and confirm that the settings were saved.

While editing the template there is a JS error in the console (screenshot), which relates to the membership plugin, but it doesn't seem to create any problems interacting with the editor of the template.

One time there were a serious of request errors relating to problems connecting to the database, but I closed the browser tab and re-opened the site and then the problem didn't re-occur.

Do you want to do some testing yourself to verify?

You can access the backend of the site here: hidden link

The credentials are the same as those you provided me for the staging site.

#2059913

Thank you Nigel, I will try to login this evening.

From my hosting service, they have replied me this:
In merito alla Sua richiesta, potrebbe essere che il supporto effettui delle operazioni in contemporanea e quindi bloccato da alcuni sistemi di protezione impostato sui servizi di Hosting condiviso.

Però per effettuare un ulteriore controllo approfondito, è necessario far ripetere le operazioni al supporto, prendendo nota dell'ip pubblico utilizzato e la data/ora in cui l'errore appare.

Regarding your request, it could be that the support carries out operations simultaneously and therefore blocked by some protection systems set up on the shared hosting services.

However, to carry out a further thorough check, it is necessary to have the support repeat the operations, taking note of the public IP used and the date/time in which the error appears.

I hope that this could be helpful to find the nature of the error inside the server.

#2062669

Hi Nigel,
Can I forward the URL and the credentials to my hosting service to access in your staging site?

#2062675

I have tried to access on it and I have a DataBase connection error message.

#2062689

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Sorry Francesco

I've been tied up in meetings, I wanted to say that I completed the testing I'm able to do on your server and have forwarded it to one of the developers (the same developer who identified the previous issue related to Divi and the use of post excerpts in the output of a View).

There are max_execuation_time errors in the logs of your staging server. One "solution" is to change your server settings to use a higher value for this setting, but this is not really a solution, inasmuch as it indicates an underlying problem that we need to investigate.

So the developer has the credentials for your site and will look into it.

I mention again that the main focus of the current development cycle (for Blocks 1.6) is a major update to how the back-end editor works when editing templates and Views, which should hopefully prevent such issues in the future, but in the meantime the developer will examine your site to see if there is some specific bottleneck they can identify that explains the stress on the server when saving the template with a View.

I'll mark this as escalated, and will get back to you, you don't need to do anything else for now.

#2064395

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Francesco

Can I just check with you what browser you are using?

The developer wasn't able to reproduce the problem on the staging server, and after sharing screens we realised the difference was I was using Firefox and he was using Chrome.

When I checked with Chrome it worked. It also worked if I used a private browser tab in Firefox.

We are investigating that, but can you confirm which browser you are using?

#2066431

Hi Nigel,
sorry for my delay in reply.

About what staging site do you refer to, staging.otrantoporto.com or hidden link?

Now I can access on hidden link.

Well, the browser I use is Firefox and sometimes Edge.