Skip Navigation

[Resolved] Split: View settings don't persist

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 50 replies, has 2 voices.

Last updated by Nigel 1 year, 5 months ago.

Assigned support staff: Nigel.

Author
Posts
#2091315

Hi Nigel,
I'm waiting for a reply from SuperPWA support.
If the reply doesn't arrive by the weekend, I will deactivate the Super PWA plugin.
If I will deactivate it, all works fine immediately or I need to do something?

#2091349

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Screenshot 2021-06-17 at 09.33.51.png

Even when you delete the plugin, any browser which visited the site while that plugin was activate will have the service worker JavaScript code installed.

If you open the browser dev tools while in the back end of your site, navigate to the Storage tab (screenshot), then expand each of the storage options in the left and delete everything within. That should eliminate what was installed in your browser storage by the plugin. (You'll need to log back in to your site.)

Also, in the Application tab you'll find sections for Service Workers and Manifests. Delete these, too.

If you use more than one browser, or more than one computer, for editing the site back end, you'll need to repeat this for each of them.

#2094489

Hi Nigel,
from the SuperPWA support I have this reply:

Extremely sorry for the inconvenience, Can you please add this below code in function.php of the theme

The below code will exclude the API URL from the cache.

add_filter('superpwa_sw_never_cache_urls', 'superpwa_support_exclude_json');
function superpwa_support_exclude_json($urls_txt){

    $urls_txt .= ', /\/wp-json/';
   return $urls_txt;
}

Do you think that this works?

#2094627

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Ya no tengo copia de tu sitio, ¿si añades el código resuelve el problema de editar el View?

#2095039

It works fine!!!! I'm happy!

#2095481

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

OK, great!

That was a very long thread for what turned out to be a relatively simple issue in the end.

I think we can close here?