Skip Navigation

[Resolved] Post Excerpt Yields "The selected field has no value"

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by trishaT 1 year, 6 months ago.

Assigned support staff: Waqar.

Author
Posts
#1885449
view page 2.png
view page.png

I am following instructions in this video for building a view page (https://toolset.com/lesson-placement/lesson-placements-1621261-1622283/ ) I set up the custom fields for "Books" to be book-image, title, author, and description. I am able to add all those fields to the view page. However, according to the video, I should be able to add the description as a standard field > current book > Post excerpt (because I want only the first 30 words) - but I get the error message that "the selected field has no value."

I can't seem to add just an excerpt.

That field was set up as WYSIWYG just as it is in the video. But on the view page, if I want the description, I have to pull it from the custom field, and it will only allow me to add the entire description, and not just an excerpt.

How can I add an excerpt to the view page? Thank you.

#1885663

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

no-excerpt-message.png
post-content-excerpt.png

Hi,

Welcome to Toolset support and I'd be happy to assist.

Can you please check your post from the screenshot ( i.e. "The Start and Grow Your Own Practice Handbook" ) and see if it has some content added into the content/body or the excerpt?

The way the excerpts work, it first looks for the post's excerpt field, and if it is empty it automatically extracts some from the post's content/body.
( attached screenshot: "post-content-excerpt.png" )

However, if the first post that is being previewed in the view editor has no content in either of these fields, then you'll see the message "the selected field has no value" and the field's length option will be set to 0.
( attached screenshot: "no-excerpt-message.png" )

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1885935

Thank you Waqar! I appreciate the great explanation, and the speed at which you responded.

I had added text only to the custom field and not to the body of the post. When I moved that text to the body of the post, it created the excerpt perfectly.