Skip Navigation

[Resolved] Custom Post Type Archive Page link from the TS dashboard throws 500 server error

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 11 replies, has 2 voices.

Last updated by Waqar 1 year, 8 months ago.

Assisted by: Waqar.

Screen Shot 2022-07-24 at 11.46.44 AM.png
Screen Shot 2022-07-24 at 11.33.33 AM.png
Screen Shot 2022-07-24 at 11.34.12 AM.png

Tell us what you are trying to do?
I was laying out an Archive Page for my new CPT (Partners) created with TS. I first used the vanilla WP blog layout as a test and once everything worked as expected, I added a Kadence Info Box (outside the Loop area) to continue experimenting with the layout. I was able to link WP Title & Post Excerpt data with the Info Box, but when I tried to pull the image from Custom Fields I was provided with only "Author Picture URL" as an option (see screenshot). So I decided to see if it would work using a Featured Image instead, but still no go. Then suddenly, when refreshing the Archive template builder page I received a 500 Internal Server Error. Puzzled, I tried to access it from the TS Dashboard link and still received the error, which continues to persist this morning (see screenshot). (I cleared browser and server caches.)

So last night I contacted my host (SiteGround). They did some poking around and provided me with this:
2022-07-24 06:09:18.829670 [Sun Jul 24 06:09:18.829622 2022] [core:error] [pid 44676] [client] End of script output before headers: post.php, referer: hidden link

To continue troubleshooting this morning, I created another CPT to see if I could access its related Archive template from the TS Dashboard. It worked, so guess it's just the Partners CPT Archive template builder that's tanked at the moment. And since I can't access the Partner CPT Archive backend, I can't continue building out the page, which is frustrating as I'm on a tight deadline and have other CPTs to also build as well. When I was deciding on a CPT/Layout plugin, I noticed that Toolset is compatible with certain Kadence Blocks, in particular Info Box, which is primary reason I chose Toolset.

Is there any documentation that you are following?
I have been watching this video.

Is there a similar example that we can see?

What is the link to your site?
hidden link (Archive Page Frontend)
hidden link (Archive Page Backend - 500 Error)

Thank you in advance for your help with this!



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how this post type and the archive are set up in the admin area.

Can you please share temporary admin login details in reply to this message? I'll also need your permission to download a clone/snapshot of the website, in case it needs to be investigated on a different server.

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.




Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

I've performed some tests and research and confirmed that the blocks with the dynamic source settings (like the "Info Box"), can be used in the loop of the WordPress Archive to show the information of the loop item post. But using it outside of the loop to show the current archive page's information is not officially supported.

You're welcome to submit a feature request for this at:

As for the already affected archive "Partners Archive Page", you can create a new WordPress Archive and assign it to be used for the "Partners" post type archive page and delete the old one.

If you could also share the details about the information you wanted to show outside the archive's loop, I'll be able to share some workaround, accordingly.


Thank you for your reply, Waqar. I actually don't need to include a block outside the WP Loop, I was just testing there (mindlessly) to see if the Info Box worked at all, not realizing it would create a problem.

I used your instructions to set up a new Partners Archive (hidden link), but have now run into these new issues. I would appreciate any assistance/work-arounds you can provide, as the launch of the new site looms in just a couple of days!!

1) CRITICAL "InfoBox Quick Layout Presets" > "Link" - I am unable to link the Archive page entries to their respective pages. (This functionality worked without issue when I did the previous test with the default WP archive layout.) I even tried creating a Custom Field with the related page URL to see if I could get at it that way, but no luck. (Please see screenshots.) Right now when you click on an Archive page element it refreshes to the Archive page instead of to the respective individual Partner page.

2) CRITICAL "InfoBox Quick Layout Presets" > "Link Content " > "Entire Box" places underlines under all of the box elements. This is not the expected behavior for Kadence Info Boxes. (See Host an Event page: hidden link) I attempted to fix this with CSS, but couldn't see any classes/ids I could target to remove "text-decoration" from the title, content and button. The admin area view doesn't match the live page. (See screenshot)

3) "InfoBox Learn More Settings" - The buttons fill the width of the Info Box instead of inheriting the Info Box settings used elsewhere in the site. (Again see Host an Event page: hidden link) There should be a setting to specify the button width if it won't be inherited. Here, too, the admin view doesn't match the live page. (See screenshot)

4) Repeatable fields display commas between the content. How do I remove or hide them. (See Alchemy on Demand page under "Contact" hidden link and screenshot.)

5) The "View on Front End" link goes to the site Home page, instead of to: hidden link so I have to manually enter the URL each time I want to view the updated page.

Thanks again!


I haven't received any confirmation of receipt for the above support request. Please let me know when I might receive a reply. Thank you!



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I want to confirm that we have received your recent replies.

I'm currently performing some tests on my website based on your shared points. I'll share the findings as soon as this testing completes, ideally within the next couple of hours.

Thank you for your patience.



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting and here are my findings.

1). When setting a dynamic source for the "Info Box" block, you'll see two options with the title "Post URL".

The first will be under the heading "POST" and the other will be under the heading "META RELATIONSHIP". I've selected the first one and the container is now acting as a link.
( screenshot: hidden link )

2). To remove the text underline style, you can include the following CSS code in the archive's "Custom CSS":
( screenshot: hidden link )

a.kt-blocks-info-box-link-wrap {
text-decoration: none !important;

3). To stop the learn more button from filling the full width, you can additionally include the following CSS code:

.kt-blocks-info-box-learnmore-wrap {
display: inline-block;
width: auto;

4). To show the repeatable field "partner-website" this is the Types Fields API shortcode that is being used:
( ref: )

<p>[types field='partner-website' target='_blank' separator=', '][/types]</p>

If you don't want to use the ', ' as a separator, you can replace it with a "<br>" tag, so that each item starts from a new line, instead:

<p>[types field='partner-website' target='_blank' separator='<br>'][/types]</p>

5). I see the issue with the "View on front-end" link on the "Partners Archive" archive's editor, but couldn't reproduce this on my test website.

Can you please delete or complete the unfinished WordPress Archive "Test Archive" and see if it has any effect?

In case the issue persists, I'll need your permission to download a clone/snapshot of this website, to investigate this on a different server.


Many, many thanks Waqar! I'm working though the updates you sent. (See notes below. )

I'm also about to set up two other CPTs with Archives for this site and wondering if it's possible to duplicate my Partner Archive, link the copy to a new CPT and make revisions, rather than having to do all of the Archive settings again from scratch? Also, is it possible to insert Archive items into another page?

1) I still had trouble with the Post URL linking to the Single Archive pages. I had the same settings as the ones you sent and it still wouldn't work. So,I fiddled around with the settings under the "Dynamic Sources" section and eventually it worked. (I should have kept better track of what I was doing, as I'm not sure which tweak finally made the fix.)

2/3) Text-decoration and Button width CSS worked great!

4) I haven't tried this yet.

5) As requested, I've deleted the "Test Archive".



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad that points 1-3 worked.

I'm confident that the solution for point 4 will work too.

For point 5, I don't see any effect of deleting the "Test Archive", on the "View on front-end" link.

Do I have your permission to download a clone/snapshot of the website, to investigate this on a different server?


Thanks Waqar! My apologies for the delay in responding. Yes, you have my permission to download a snapshot of to troubleshoot the "View on Front End" link.



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for the permission and I've downloaded a clone of the website.

I'll be running some tests on this clone and will share the findings, as soon as this testing completes.

Thank you for your patience.



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

During troubleshooting, I discovered that the incorrect "View on Front End" link in the archive was caused by the plugin "Simple Post Type Permalinks".

Please go to WP Admin -> Settings -> Permalinks and change the permalink setting for the "partners" post type, from 'Default' to '/partners/%postname%' and then save the settings, and it will be fixed.
( screenshot: hidden link )

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.