Skip Navigation

[Resolved] Cannot use filtered search as menu item or direct URL

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 10 replies, has 2 voices.

Last updated by scottL-3 9 months, 4 weeks ago.

Assisted by: Waqar.

Author
Posts
#2599661

I am trying to:

Use a URL like hidden link as a menu item

Link to a page where the issue can be seen:
hidden link

I expected to see:
The page with the filter applied

Instead, I got:
The page without the filter and without the URL parameter in the browser location bar. The page came up as
hidden link

I have tried disabling WP Rocket, disabling various other plugins, PHP 7.4 v. PHP 8.1, looking for clues in the browser console, directly typing in the URL with the parameter, etc. different browsers and no change. I have also enabled WordPress Debug and looked in the log file where there were no clues, just some deprecation warnings if I use PHP 8.1.

Since it only happens on the live site and only happens when not logged in, I can't extensively disable plugins with the Check Conflicts plugin or manually as I'll affect all visitors.

This only happens when not logged in to the site. If I am logged in, it works correctly.

It does not happen on our staging site which is up to date with the same plugin versions. I'm going to update our staging site from our live site to see if I can get the problem to happen there so we can try more things to find and fix it.

In the meantime, any tips on what else to check? Is anyone else having an issue like this?

#2599871

Now I'm seeing other issues that seem related to this one. I can't use pagination in a view where it used to work:
hidden link

If you click a page number in the pagination control, you get page 1 no matter what.

#2600051

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

Your website seems to be using 'WP Rocket' and is also being served through Google's CDN service.

Have you checked if your CDN or hosting server is applying any cache or optimization on its own? It would be a good idea to test this website's clone on a different server where the 'WP Rocket' CDN service is not in use.
(even a localhost server will do)

regards,
Waqar

#2600147

I have removed WP Rocket with no change so I put it back. We do not use a CDN.

I get the same problems on our staging server that uses no caching.

If I roll WordPress back to 6.1.1, the problem goes away. There is an issue with Toolset and WordPress 6.2.

Our staging site is a copy of our live site with WP Rocket and a few other plugins disabled. It had the same problems until I rolled it back to WordPress 6.1.1. You can see the difference:

On the live site at hidden link, pagination doesn't work. This is WordPress 6.2
On the staging site at hidden link, pagination works. This is WordPress 6.1.1

#2600831

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these observations.

I've performed some tests on my website with WordPress 6.2 and 6.1.1, but couldn't reproduce these issues. Also, we haven't received a report like this from any other user.

Can you please share the temporary admin login details of the staging website, so that I can see how different elements are set up? I'll also need your permission to download a clone/snapshot of the website, to test this on a different server, if needed.

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

#2601767

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

Just wanted to let you know that I'm still working on this and will share the findings today.

Thank you for your patience.

#2602711

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I've completed the testing on your staging website and its clone (on a couple of different servers) and here are the findings:

1. The main challenge that you're noticing on the live website is that on any page (whether there is a Toolset view involved or not), the URL strings or query parameters are getting stripped.

It doesn't matter if the link is coming from the pagination or the navigation menu item.

For example, try adding some random URL parameters to the homepage URL (live website) and open it in a new browser tab:
{yourwebsite.com}/?test=test

You'll see that it will redirect back to the homepage, stripping the URL parameter ?test=test
{yourwebsite.com}/

2. This doesn't seem related to the WordPress version as I couldn't reproduce this on your website's clone on multiple test servers with the same PHP version.

Even if you'll check your staging website now, you'll see that the issue is not reproducible there either, despite the fact that it is updated to WordPress 6.2.

3. Most likely Wordfence plugin on the live website is stripping out any query strings from the URL, thinking of them as malicious.
( that is the only plugin that I had to disable on your website's clones so that I could log in to the admin area )

I'll recommend getting in touch with Wordfence's official support team to discuss this matter further.

#2602815

I don't know why it started working on staging but I don't think Wordfence is the issue. I've tried disabling Wordfence on the live site and it does not fix the problem there.

I also have other sites with Wordfence where this issue is not occurring.

#2602829

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Is there any other extra security plugin or layer/firewall enabled on the live website?

Can you share the temporary admin login details of the live website?

I'm setting your next reply as private and please make a complete backup of the live website first.

#2603283

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access to the live website and no changes have been made to it.

During troubleshooting, I discovered that the Yoast SEO plugin's "Advanced: URL cleanup" feature was causing this behavior.
hidden link

You can either disable the 'Remove unregistered URL parameters' option or add the relevant URL parameters in the allowed list at WP Admin -> Yoast SEO -> Settings -> Advance -> Crawl optimization.

#2603325

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.