Skip Navigation

[Resolved] With Toolset Access activated, I cannot create forms with WS Form PRO

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)


I've been working with the author of WS Form PRO regarding an issue with not being able to create forms when Toolset Access is also activated.
In my case it appears to be the combination of Toolset Access and Kadence Blocks.

I've verified this on multiple websites and have not issue replicating this issue on other sites, even brand new sites with only those plugins installed.

The issue presents for me as not being able to create new forms using WS Form Pro. When I attempt to create a new form I get a WSOD.

Mark from WS Form Pro mentioned that he was going to sent you people an email about this but I thought I'd also chime in with some real world examples.

Mark mentioned that changing Line 141 in types-access/application/controllers/permissions_post_types.php from "$tmp_post_type_object->map_meta_cap = true;" to "$tmp_post_type_object->map_meta_cap = false;" is the solution, and it worked on my bare bones test site, but did not work on the website that I need it to work on.



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting us and I'd be happy to assist.

I tried to log in to the website's admin area, but it keeps showing this message:

"ERROR: You have been temporarily banned from logging in."

Before we investigate this deeper, I'll recommend a quick test. It would be interesting to test if the issue is reproducible only when logged in as a specific user.

For example, if the website only has a single 'administrator' role user, you can create a new one and see if that user also can create forms or not.

Let me know how it goes and if the issue persists, I'll need your permission to download a clone/snapshot of the website to test it on a different server.



Whoops, I restored a backup that didn't have the account I listed. I just re-added it and tested. All plugins are deactivated that aren't related to the issue.
I also have a basic test site set up with only those plugins installed if you need it.



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

I've tested your website's clone on my test server and made an interesting observation.

I was not able to create a new form, even with all the plugins disabled, except for 'WS Form PRO' and with the default 'Twenty Twenty-One', with PHP 8 (specifically 8.2.0).

There were many depreciation notices and warnings, but no fatal error.

Your website's server is also using PHP 8. Can you test this with the PHP version downgraded to PHP 7? You can also turn on WordPress debugging and see the errors and warnings recorded in the error log.
( ref: )

I hope these findings will help and let me know how it goes.


I've added
[code]// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );[/code]

to my wp-config.php and set my PHP version to 7.4
Site Health Info reports 7.4.33

No change in the ability to create forms with WS Form Pro


Any news or progress?



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

I've received an update from the development team, who are also in touch with the Mark from WS Form Pro.

We plan to introduce a fix for this compatibility issue in the next release of the Toolset Access plugin.

For the particular website in question can you remove the current Access plugin, download and install the latest copy, and then make the suggested change from Mark?

It works on all our test websites.


Hey Waqar, I deleted Toolset Access, re-uploaded and activated, made the change that Mark suggested, and things are working as expected now.
I confirmed again on another test site 🙂

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.