Skip Navigation

[Resolved] We've a map view with many markers, but we're using clustering. It's still slow

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.46 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 1 reply, has 2 voices.

Last updated by Waqar 1 year, 2 months ago.

Assisted by: Waqar.

Author
Posts
#2537465

We 've got a map view with lots of markers, but we're using clustering. It's still super slow sometimes, even with caching. Can someone see if it's something we've done or it's just the reality of having lots of markers? See here: hidden link

#2537691

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I've checked that page on a couple of different devices and browsers and noticed that it loads under 10 seconds, every time.
(usually between 7-9 seconds)

Considering that there are over 1700 map markers that need to be rendered on the map, this is a fairly good loading time.

Are you experiencing slow loading, at some particular time or in any specific device or browser? And does that only happen when you're logged in as the 'administrator' user?

Note: When logged in as the 'administrator' user, there are certain background tasks that need to be run, so it is normal to experience higher loading times, compared to non-admin users or visitors.

regards,
Waqar

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.