Skip Navigation

[Resolved] userform

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 12 replies, has 2 voices.

Last updated by yoshihikoH 1 year ago.

Assisted by: Minesh.

Author
Posts
#2590265
test-mail.jpg
userform.jpg

Dear

The placeholders mentioned in the userform email body do not work, so I would appreciate if you could think together about the cause.
Please refer to the attachment.

Regards,

Yoshihiko

#2590433

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

It seems you are using a text email and with test email it will not work.

Have you tried to submit the user form and check if you can get the email with actual values.

#2590441

Dear minesh

Thank you for contacting
First, the site is a membership site.
I'm getting charged when users register to subscribe to articles.
As you point out, I was charged with membership registration, but I didn't receive a confirmation email to the customer. So it was up to me to try sending the test, but the results were as attached.

Regards,

Yoshihiko

#2590461

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please make sure that you followed the steps given with the following Doc:
=> https://toolset.com/course-lesson/charge-users-for-registering-premium-accounts/

#2590469

Dear minesh

I have completed all the basic settings.
I have confirmed that woocommerce and Stripe are all working properly.
However, I am asking a question because the user form does not work.

Thank you,

#2590471

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I recommend you install a mail logging plugin to record what attempts are made to send emails.
=> https://wordpress.org/plugins/wp-mail-logging/

Do you see the mail is sent successfully? Have you submit the form?

#2590475

Dear minesh

I'll install wp-mail-logging, but the problem is not that, but the settings from placeholder like User Name=%% USER_USERNAME%% don't work.
It seems to me that a placeholder like these doesn't work, whether the email was sent, rather than the problem being hidden elsewhere, is it different?
By the way, wp-mailsmtp is set and sendinblue is working properly.

Regards,

ypshihiko

#2590497
mail-logging.jpg

Dear minesh

Please refer to the attached image
If I newly registered for membership on the user form, the confirmation page from woocommerce will be sent to the registered email, but it seems that the toolset user form did not send the email. This means that the user form is not working. It was clear that the email from the user form did not fly. Please tell me how to deal with it.

Regards,

yoshihiko

#2590877

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please share problem URL where I can see the form as well as admin access details and steps I'll have to follow to submit the form. If required, please also share frontend user access details as well.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#2590995

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please also share the problem URL and exact steps I'll have to follow to see the issue.

I have set the next reply to private which means only you and I have access to it.

#2591889

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Maybe it seems you missed my previous reply.

Can you please also share the problem URL and exact steps I'll have to follow to see the issue.

#2592895

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm not sure what email you are looking but I can see the email is available with email log as well as I can see the email in my inbox as well.

Please check the following screenshot: hidden link

#2592935

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.