Skip Navigation

[Resolved] Toolset User Form repeat password box not working in Firefox browser

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 6 replies, has 3 voices.

Last updated by simonM-5 6 months, 3 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#2365077
Screenshot 2022-05-17 at 13.48.57.png

Hi Support

Password validation in the Repeat Password box is not working for us in Toolset User Form "User Form - New Native Nanny User", only in the Firefox browser.

In Safari and Chrome, we are not facing the issue.

When we type in an identical password in the repeat password box, Firefox tells us the passwords don't match (here I'm just using a simple 123 in both fields).

Any idea why Firefox is behaving differently than the other browsers and how we can overcome this?

Steps to reproduce:
1) hidden link
2) Click Become a Native Nanny
3) Enter same password twice in the user form

Thanks and kind regards
Simon

#2365217

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Simon

I just tested a user form to register users which contains two password fields, and it worked as expected in Firefox.

I expect the problem may arise because of customisations you have on your site.

Can you please try removing any custom code associated with the form (PHP or JavaScript) and re-testing? If it still has the same problem, can you eliminate the possibility of conflicts by disabling all non-Toolset plugins and switching theme to twentytwentyone or similar.

Does that affect the validation problem?

#2366111

Hi Nigel

Some updates from our testing:

- We have seen the same issue now in Safari, but sporadically. It always occurs in Firefox.
- The user form "User Form - New Family User" for the "Register as a Family" section is exactly the same, the only difference being it creates users of a different role, but the issue never occurs there.
- The user form "User Form - New Native Nanny User" where the error is occurring also has the error when the JavaScript is commented out. The JavaScript section is only there to ensure that First Name and Last Name are always filled out.
- Removing all styling in the Elementor tabs widget in the div tag containing the form did not help either.
- The issue does not appear to occur when only Toolset plugins are active on their own
- The issue only seems to occur when Elementor is active.

I changed the page completely just to give the user two options to hyperlink from to existing pages but if perhaps you may want to investigate why displaying the User Form inside an Elementor Tabs widget leads to the error (I'll leave this up to you!)

Kind regards
Simon

#2366479

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

passwords.jpg

Hello,

I have tried these in your website:
1) Open URL:
hidden link
2) input value 123 into both password fields, I don't see the problem you mentioned above: Firefox tells us the passwords don't match
It works fine, see my screenshot passwords.jpg

Is there any missing steps? is this problem resolved?

#2366691

Hi Luo

As mentioned in my previous update, I solved the issue myself by using a different solution, but Toolset still may want to investigate why this doesn't work when the form is placed within an Elementor tabs widget.

Up to you guys!

Kind regards
Simon

#2367369

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since it is a compatibility issue with other plugin(Elementor), I don't have the latest version of Elementor plugin in my localhost, if you need more assistance for it, please reproduce the same problem in a fresh WP installation test site, and provide the test site copy in below private message box, also point out the problem page URLs, I need to test and debug it in my localhost

#2367553

My issue is resolved now. Thank you!