Skip Navigation

[Resolved] Template for editing posts doesn't work

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 5 replies, has 2 voices.

Last updated by rubenM-3 5 months ago.

Assisted by: Waqar.


I have created a type of posts called Negoci, with Toolset. I want my registered users to be able to add and modify their posts. I have no problem with the process of creating a post, it works correctly. On the My Account page, the user's page, I have a view (negocis-autor) that shows all the user's posts.
On that page, inside the view, I want to make a button to go to a page where I can edit the post. Here comes the problem.
I have created an edit form for the post type Negoci. I have created a template, without assigning any type of posts, and I have inserted the form. Although the website is made with DIVI, I created this template with the block editor. Then I went to the corresponding view, and tried to create an "Edit post link" using the template. The shortcode that appears is this:

[toolset-edit-post-link content_template_slug='3883' target='self']Modificar[/toolset-edit-post-link]

No link appears in the view. How can I know if the template is correct, because if the image and the name of the post appear, the link does not appear?

Thank you!



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how this edit form and the edit content template are set up in the admin area.

Can you please share temporary admin login details, along with the link to the page where you've included this edit link?

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.




Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

I found the account page named 'El meu compte' where this view is in use.

When I temporarily removed the post author filter from the view, it started showing the results, along with the post edit link.
( screenshot: hidden link )

And the edit link properly pointed to the relevant single post pages, with the 'Template Editar Negoci' content template that holds the edit form.

Can you please test the accounts page again with a user who as has at least one 'Negocis' post as an author?


Hi Waqar,
thank you for your help,
If you go to login page, hidden link, you can login as


And in page My Account, hidden link, you can see "imesdisseny" a post created by this user. There is where I can't see Edit link to template.

Thank you!



Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

This user belongs to the user role 'Negoci'.

From WP Admin -> Toolset -> Access Control -> Toolset Forms -> Post Forms Front-end Access Group, I enabled this user role so that it can use the 'Editar Negoci' form to edit its own posts.
( screenshot: hidden link )

Now, you'll see the edit link, when logged on as that user.

Here is a useful guide on this topic:


My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.