Skip Navigation

[Resolved] Silder hides first image when there are 3 items

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 7 replies, has 2 voices.

Last updated by Waqar 1 month, 3 weeks ago.

Assisted by: Waqar.

Author
Posts
#2682604
Screenshot 2024-02-09 at 9.36.36 AM.png

Hello,

I'm using a view to display an image repeatable field as a slider.
When there are only 2 items, it works fine. Like here: hidden link (I'm talking about the slider of images on the left)
When there are 4 items, the first items shows twice and we don't see the third item: hidden link
When there are 3 items, the first item doesn't show. hidden link

This is really odd. I will insert a capture of the parameters I used for the pagination. Any idea why this could happen?

thank you for your help!

#2682809

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how this view and the relevant posts are setup in the admin area.

Can you please share temporary admin login details, in reply to this message?

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

#2683613

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

While I can see the issue with the posts coming from the view 'Silder Images Look', I couldn't reproduce this on my test website.

This suggests that something specific to your website is involved. I had limited access so couldn't view the active plugins, but for further troubleshooting, I'll suggest the following steps:

1. Please make sure that WordPress, active theme, and plugins are all updated to the latest versions.

2. It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty-One.

If it's fixed, you can start adding the disabled items, one by one, to narrow down to a possible conflicting one.

3. In case the issue persists, I'll need your permission to download a clone/snapshot of the website, to investigate this on a different server.

#2684462

Hi Wagar,

I updated everything but the issue remains. I try deactivated all the plugins and the issue was still showing. However I couldn't change the theme because if I do, nothing is visible sa I'm using Flatsome shortcodes.

I would appreciate your help. Let me know if you need any further information. Thank you! You have permission to clone the website.

#2684922

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for the permission.

I tried to download the website's clone, but my user is not allowed to install plugins. I'll need to install the plugin 'Duplicator Pro' to download this clone.

Can you please elevate this user's role to 'super admin'?

#2684971

Hi Waqar,

I changed your privileges. Let me know if you can do everything you need now. Thank you!

#2685234

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for the permission and I was able to download the website's clone.

I'm currently running some tests on this and will share the findings, as soon as this testing completes.

#2685460

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

During troubleshooting your website's clone, I noticed that it was not having the same issue on my test server.

This suggests that something specific to your hosting/CDN optimization measures are interfering with this.

Additionally, on your website, if the view 'Silder Images Look' is set to order based on "Post ID", instead of the 'Menu order', it also fixes it on your server.
( you can see it working at the moment on your website's product pages )

#2685493

Hi Waqar,

It seems mostly resolved indeed. Thank you. Some are still a bit wonky but we can accommodate.

Thank you for your help!

hanaelS confirmed that the issue was resolved on 2024-02-27 17:35:31.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.