Skip Navigation

[Resolved] Shortcode transition

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 4 replies, has 2 voices.

Last updated by yoshihikoH 1 year, 5 months ago.

Assigned support staff: Minesh.

Author
Posts
#2136191

I would like to ask about shortcode transitions.
Shortcode set in My Account page
For example, <a href="[wpv-post-url item=81]"> Posted for 1 week </a> will transition correctly.
However, it will not transition correctly from the same short code set in the fixed page.
Why does this difference occur?

Thank you,
yoshihiko

#2137377

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

I do not understand what you mean by " it will not transition correctly from the same short code set in the fixed page.".

Can you please share few screenshot or problem URL or bit more details what exactly code you are using and where and what it outputs on frontend.

#2137727
screencapture-2.png
screencapture-1.png

I am making a site that requires a charge for posting.
Weekly posts will be charged for one week.
Here's the code that takes you to the page that lets you post for a week:
<a href="[wpv-post-url item=81]">Posted for 1 week</a>

・screencapture-1

The image is a capture of the pc. The toolset form for transition is displayed on the PC. I have attached a capture on the pc that is displayed.
However, the toolset form is not displayed on the smartphone and the required items cannot be entered.
screencapture-2

My question is why it doesn't appear on my smartphone.

Regards,

Yoshihiko

#2138541

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Have you grant the Guest user access to your form?

Go to the Toolset → Access Control page and click the Toolset Forms tab.

Depending on the type of a form you want to edit permissions for, click to expand the Post Forms Front-end Access or User Forms Front-end Access section.

A table appears, with a lists of all user roles and their access to available front-end forms and permissions.

More info:
- https://toolset.com/course-lesson/controlling-access-to-front-end-forms/

#2138635

My issue is resolved now. Thank you!