Skip Navigation

[Resolved] Reading->Search engine visibility (blog_public) stuck

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.76 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 7 replies, has 2 voices.

Last updated by katjaL 1 year, 8 months ago.

Assisted by: Luo Yang.

Author
Posts
#2464027

Strangest problem which I never had before. This is a Toolset reference site installation with which I had problems, the installation didn't work as suspected, Shane installed it with some other way. Here is about that problem: https://toolset.com/forums/topic/reference-site-install-not-working/

Now the Settings->Reading->Search engine visibility->"Discourage search engines from indexing this site" is stuck, it's activated even I de-activate it and save. I also have changed the blog_public value in database, still the option in WP is the same.

I cloned the site, same problem there. What should I do?

#2464745

Hello,

The credentials you provided in above thread was removed to protect your privacy:
https://toolset.com/forums/topic/reference-site-install-not-working/#post-2430467

Please check these in your website:
1) check if there is any PHP/JS error in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

2) If the problem still persists, please provide a copy of your website, you can put the package files in your own google drive disk, share the link only, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#2464777
dropbox.jpg

I have tried the URL you provided above, but get below error message and can not download the files:
.zip files are supported but something went wrong.

See my screenshot dropbox.jpg

Please check it, make sure it is valid to download, then update here

#2464817

Perhaps the package hadn't uploaded yet, sorry for that. Now the link should work.

#2464837

Thanks for the details, I can see the problem with your duplicator package, the problem persists even after I deactivate all Toolset plugins, it is in the drop-in plugin "maintenance", you can try these:
Delete the file wp-content\maintenance.php

And test again.

#2464853

Thank you. Deleting the maintenance.php didn't help.

#2464873

Please try these:
Delete(or rename) both files:
- wp-content\maintenance.php
- wp-content\mu-plugins\

And test again

See the plugin file: wp-content\mu-plugins\autologin.php, line 2:

add_filter( 'option_blog_public', '__return_zero' );

Above codes will set the "Search engine visibility" option to be checked.

#2464909

Yes, that was it! My issue is resolved now. Thank you!

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.