Skip Navigation

[Resolved] Query filter gets deleted.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 4 replies, has 2 voices.

Last updated by matthiasV-2 1 year, 3 months ago.

Assigned support staff: Waqar.

Author
Posts
#2193183

Refer this ticket to Waqar, please.

We are trying to setup this query filter for multiple pages:

Field - Development index
The field Development index is a number that is greater than or equal to the following:
Constant: 70

However the query filter is only saved for one page, it gets deleted all the time for the other pages.

What is going wrong?

#2193465

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Can you please share details about on which page the query filter is saving and on which pages, it doesn't?

The screen capture video of the steps to see the issue would be very helpful, in this case.

I've set your next reply as private.

regards,
Waqar

#2193581

Waqar,

The query filter:

Field - Development index
The field Development index is a number that is greater than or equal to the following:
Constant: 70

is saving for:

- hidden link

is NOT saving for:

- hidden link
- hidden link

Steps to take:

Open the respective pages
Go to View > Content selection > Query filters
Try to save the above query filter
You will see that the filter does save first BUT if you re-open the respective pages the filter is no longer saved, instead it saves the filter:

Field - Development index
The field Development index is a number that is greater than or equal to the following:
URL parameter: wpv-wpcf-development-index (instead of: Constant 70)

#2193899

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

On the first page ( Acquisitie opportuniteiten professionele kopers met en zonder verkoopintentie ), where the query filter is saving, there is no front-end search field for the "Development index" field. This is why the query filter for that field can be set statically in the view's query filter settings.

However, in the views used on the other two pages, where the static query filter is not saving, the front-end search field for the "Development index" field is added in the search form. As a result, no matter what static query filter you'll set in the view's settings for this field, it will revert back to be linked to the associated front-end field.

If you'd like to set a static query filter for this field in the view's setting, you'll need to remove the associated front-end search field from the view's search.
( screenshot: hidden link )

#2193963

My issue is resolved now. Thank you!