[Fixed in next Release] Problem with new DIVI block (Gutenberg) and Toolset templates

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Nigel 1 month ago.

Assigned support staff: Nigel.

Author
Posts
#1455527

Hi,
The DIVI block element is not shown in the Gutenberg block editor when a Toolset template is being built.
I don't know if this will be a Toolset problem or a DIVI problem, but you should agree so that the DIVI block can be displayed in the Gutenberg block editor for a Toolset template.
This is very important so that DIVI elements can be included in the Toolset templates.
Look at video: hidden link
Thanks for your help.
Regards,
Jose

#1456065

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Jose

I suspect that the Divi block element is registered to only appear for certain post types, and that the Toolset template post type isn't one of them.

We've already had this reported, though I haven't been able to test it yet as I haven't the newest Divi update available. I've asked for an update from our compatibility team, there may be some setting relating to the supported post types.

For now I'm adding this thread to the already escalated ticket, and I'll get back to you when I have an update.

#1516099

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Jose

I'm just back from a break and wanted to let you know that the fix for this compatibility issue has been released.

I tested it myself and found that it works, but understand that a handful of clients are having problems with it—and it seems like you may be one of them, I see that Minesh has an open ticket with you that looks related.

Which means that this ticket can be closed, I think.

#1524619

Hi Nigel,
Yes. Now the DIVI block is shown in the Toolset templates, but it cannot be used, that is, it is as if it was not shown. 🙁
Look at the following tickets:
https://toolset.com/forums/topic/problem-with-divi-block-and-toolset-templates/
https://toolset.com/forums/topic/patch-for-divi-layout-block-in-toolset-block-template-not-functioning-fully/

Regards,
Jose

#1525019

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

I've asked Minesh to check the internal ticket and provide you with an update, the developer has identified a problem in specific circumstances, and I don't know if they apply to you.

I went ahead and tested this again on my own local test site which has current plugin versions and it works, although...

When I insert a Divi Layout cell into a Toolset Content Template I can create a new layout directly from within the block (in my test just some text inside a text module), and when I Save and Close it I return to the Block editor, where the Divi Layout block shows a neverending spinner, i.e. no preview of its content.

But if I save the template and then visit a post on the front end, I see the content of the Divi Layout block rendered, so it is saved and works, it is the back-end preview that is missing.

#1525233

Hi Nigel,

My case is a little different from yours, I can't create the layout.
Watch the following video: hidden link
If you want I can give you access to my dashboard.

Regards,
Jose A.

#1526469

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

I know Minesh (who was able to reproduce the same issue you report) is re-testing your issue.

I got further in the process and found it works, except the spinner is shown instead of the preview after saving the Divi Layout block, but upon updating the page it works on the front-end. So a minor usability issue in my experience. I've asked other colleagues who were unable to reproduce what you described in terms of the never-ending spinner preventing you from beginning the process if they see the same as me when they try to complete the process, and shared my findings with the developer who is working on this.

When I have more news I'll let you know.

#1527195

Ok. Thanks Nigel.

#1530227

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

The developer who identified a particular issue when using the Divi Layout block inside a template has added a fixed, and that has gone to our testers who confirmed the fix, that they were able with a template to insert a Divi Layout block, design it, and save it.

So I'm going to mark this as fixed in next release, and I'll let you know when the next Blocks update is published.

Looking at the remaining tickets for that release I expect there are still a couple of weeks required.