Skip Navigation

[Resolved] Please, select an user role before creating a Form

This support ticket is created 5 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 2 replies, has 3 voices.

Last updated by nicolaS-3 5 years ago.

Assisted by: Luo Yang.

Author
Posts
#1224244
ppp2.jpg
ppp1.jpg

I am trying to: create a user registration form

Link to a page where the issue can be seen: n/a

I expected to see: created form and generate form button

Instead, I got:

full screen error - Form User Fields not set!. If you click ok
Second error appears - Please, select an user role before creating a Form

Tried selecting different user roles, nothing helps. I'm using latest toolset plugins. Screenshots attached

#1224299
save-user-form.JPG

Hello,

I have tried it in my localhost with a fresh wordpress installation, it works fine, there isn't the same problem as you mentioned above, see screenshot save-user-form.JPG

Please check these in your website:
1) Make sure you are using the latest version of Toolset plugins, you can download them here:
https://toolset.com/account/downloads/

2) Recreate a new user form, and test again.

3) In case it is a compatibility problem, please deactivate other plugins, and switch to wordpress default theme 2019, deactivate all Custom code snippets, and test again

4) Also check if there is any JS/PHP error in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

#1379339

Hi Luo Yang,
I have a similar problem, if I try to create (with the wizard) or edit a form (that I possibly created long time ago with CRED) I get the same message "Please, select an user role before creating a Form" even though I DID select a user role (subscriber). I am on Forms Version 2.5.2.
Any clue ?
Thanks
Regards
Nicola
Avada installed Contact Forms 7 but is inactive, does this matter ?

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.