Skip Navigation

[Resolved] pagination stopped working

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 2 replies, has 2 voices.

Last updated by Waqar 2 months ago.

Assisted by: Waqar.

Author
Posts
#2684242

hi on this page the pagination has stopped working. I can see the structural div in the source but no markup within. Ive tried it with and without Ajax
hidden link

Thjis is the Search and Pagination content

[wpv-filter-start hide="false"]
[wpv-filter-controls]

<div class="form-group" id="state">
<label for="wpv-state">States or International</label>
[wpv-control-post-taxonomy taxonomy="state" type="select" default_label="Please Select" orderby="slug" url_param="wpv-state"]
</div>

<div class="form-group" id="categories">
<label>[wpml-string context="wpv-views"]Resource Categories[/wpml-string]</label>
[wpv-control-post-taxonomy taxonomy="resource-category" type="select" default_label="All categories" orderby="slug" url_param="wpv-resource-category"]
</div>

<div class="form-group" id="levels">
<label>[wpml-string context="wpv-views"]School Levels[/wpml-string]</label>
[wpv-control-post-taxonomy taxonomy="school-level" type="select" orderby="slug" order="asc" default_label="All Levels" url_param="wpv-school-level"]
</div>

<div class="form-group" id="search">
<label>[wpml-string context="wpv-views"]Text Search[/wpml-string]</label>
[wpv-filter-search-box output="bootstrap"]
</div>

<br style="clear:left;">
<div class="form-group" id="pagination">
[wpv-pager-nav-links output="bootstrap" first_last_links="true" step="10"][wpv-pager-current-page][wpv-pager-total-pages]
</div>

<div class="spinner-group">
[wpv-filter-spinner spinner="hidden link"][/wpv-filter-spinner]
</div>
[/wpv-filter-controls]

[wpv-filter-end]

Thanks for your help

#2684336

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how this view is set up in the admin area.

Can you please share the temporary admin login details, in reply to this message?

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

#2684552

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

In the corresponding view 'ListOfResourcesNonMember' (ID: 13756), the limit was set to '10' and the pagination options were set to 'No pagination'.
( screenshot: hidden link )

I've removed the limit and enabled the pagination option and it is working now.

#2684626

Argh thanks so much for seeing that

Best

Steve confirmed that the issue was resolved on 2024-02-22 13:56:10.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.