Skip Navigation

[Resolved] Issue on custom search form for distance

This thread is resolved. Here is a description of the problem and solution.

Problem: Custom placeholder HTML applied to a distance search filter is not displayed as expected after a recent Maps update.

Solution: Update to the latest version of Maps.

Relevant Documentation: https://toolset.com/errata/custom-placeholder-for-distance-filter-broken-with-maps-2-0-9/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Christian Cox 3 weeks, 2 days ago.

Assigned support staff: Christian Cox.

Author
Posts
#2125505
Immagine 2021-07-26 173151.jpg
Immagine 2021-07-26 173054.jpg

I am trying to:
Until the last update, all works fine. Now I have an issue.
This is the code that I use:

  <div class="form-group distanza">
[wpv-control-distance default_distance="50" distance_center_required="yes" compare_field="mappa" distance_center_url_param="toolset_maps_distance_center" distance_radius_url_param="toolset_maps_distance_radius" distance_unit_url_param="toolset_maps_distance_unit" inputs_placeholder="<div class='raggio'><label>Mostra Eventi entro</label>%%DISTANCE%%</div><div class='location'><label>da</label>%%CENTER%%</div>" visitor_location_button_text="Mia localizzazione"]
    </div>

Link to a page where the issue can be seen: hidden link

I expected to see: The placeholder like I have set into the View

Instead, I got: The default placeholder (see the screenshots)

#2125573

Hello, thank you for the report. I am able to replicate this problem in a similar set up test site that I started in Maps 2.0.8 and then upgraded to Maps 2.0.9, so it seems that something happened in the most recent release that broke the implementation of custom placeholder text. I have asked my 2nd tier team to investigate, and I will let you know what I find out.

#2126573

My second tier team has confirmed the problem and escalated to our developers. I'll keep you posted here as I receive additional information.

#2126603

Thank you!

#2127199

For your reference, this issue and another known issue related to the recent Maps 2.0.9 release have now been posted to our known issues list:
https://toolset.com/errata/custom-placeholder-for-distance-filter-broken-with-maps-2-0-9/
https://toolset.com/errata/cannot-specify-view-as-source-of-markers-in-map-block-following-maps-2-0-9-release/

I'll continue to update you here as I receive more information.

#2127619

Thank you.
Now I have downgraded Toolset Maps to 2.0.8 version.

#2132635

I have been informed that the custom placeholders feature will be restored in the next hotfix release of Maps. As soon as I have a schedule available for that release, I will provide another update here.

#2156157

Hello, our team is in the process of releasing a round of hotfix releases for several Toolset plugins, including the fix for this issue in Maps. If you have not yet been prompted to update, you may go to wp-admin > Plugins > Add New, click the Commercial tab, and then click "Check for Updates" in the Toolset Installer panel. You should be able to receive the automatic update for all Toolset plugins. Let me know if the issue is not resolved after updating.

#2157071

With the last update, my issue is resolved now. Thank you!

#2157311

Great, thanks for the update!