Skip Navigation

[Resolved] In the email notification setting in postform

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 26 replies, has 4 voices.

Last updated by Luo Yang 7 months, 2 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#2385355

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

In order to test the email results, I have done below modifications in your website:
1) Install and activate "Post SMTP" plugin, so can trace the email logs in your website
2) Edit the product "5000円", change the price to 0
hidden link
I don't have VISA card to buy your product.

Test it in frontend:
hidden link
Fill and submit the form, and complete the payment.
Check it in the admin side, email logs:
hidden link
I can see the "Thankyou" email correctly, can you confirm it?

#2385423

Dear Luo,

Thank you for your support.
I have confirmed that the email is sent correctly.
Thank you very much.
What is the biggest reason why the email was not sent?
The postSMTP plugin is working, isn't it? Please tell me the function (meaning) of this plug-in.
I would like to wait for your reply and close my ticket.

Thank you,

Yoshihiko

#2385531

My issue is resolved now. Thank you!

#2386099
postman-error.png

Dear Luo,

I changed postman to sendinblue on the postSMTP. setting screen.
I concatenated the API key to postSMTP.
When sending a test email, I'm sorry for the Ajax error.
Can you support me?

Regards,

Yoshihiko

#2386121

Dear Luo,

I contacted you earlier, but it has been resolved.
Currently, postsmtp and postman (sendinblue) seem to work together.
There is one problem.
The email I set in the postform is not working correctly.
Excuse me, can you please support me?

Regards,

Yoshihiko

#2386195

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Please elaborate the new question with more details:

The email I set in the postform is not working correctly.

How should the email be correctly?
Where can I see the email isn't correctly?

And the website credentials you provided was removed:
https://toolset.com/forums/topic/in-the-email-notification-setting-in-postform/#post-2385127
Please provide new credentials in below private message box, thanks

#2386273

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, please check these:
1) In the post form:
hidden link
Email notification: 会費納入のお知らせ
You are using setting: When post status changes to "完了"

2) But after user complete the payment, the Woocommerce orders post status are still in "Pending" status, so it conducts the problem.

You can try one of below option:
1) Change the order status to "完了", it works fine in your website Manually:
hidden link
See item: DDP納入が完了しました。
More help:
https://woocommerce.com/document/managing-orders/

2) follow Woocommerce document to setup custom codes to complete the order after payment automatically:
https://woocommerce.com/document/automatically-complete-orders/

#2386369

Dear Luo,

You have removed the postSMTP plugin. Last time you set up this plugin, is there any reason?

Regards,

Yoshihiko

#2386403

Please ignore the previous email.

#2386575
postform-3png.png

Dear Luo,

I am grateful for your support.
I was also able to confirm the email sent from woocommerce after the order processing was completed.
There is only one problem left.
What is the reason why the email described in the Notification e-mail body of the postform e-mail Notification is not sent?
Please refer to the pasted file. When the Japanese described here is translated into English, it is described as follows.
---------------------------------------------------
[wpv-post-title]
Thank you for paying the membership fee. Thank you very much.

We look forward to your continued support for the Tohoku University Judo Club.

%% DATE_TIME %%
Takao Kikuchi, Chairman of Tohoku University Judo Club Supporters Association
------------------------------------

#2387087

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can see the problem in your website, will update here if find anything

#2387099

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have done below modifications in your website:
1) Dashboard-> Settings-> General:
hidden link
Change below option values:
- WordPress Address (URL)
- Site Address (URL)
from "http" to "https"
It should be able to fix the email problem

2) Edit the post form:
hidden link
in section "E-mail Notifications"
option "Notification e-mail trigger", change to "When the purchase status changes to: Completed"
option "Notification e-mail body", change the post title from:
[wpv-post-title] 様
To:
%%POST_TITLE%% 様

Test it again, I can see two emails are sent once the Woocommerce order is completed, please check if it is fixed, thanks