[Resolved] Hiding some custom fields on admin side when editing a post

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Luo Yang 1 month ago.

Assigned support staff: Luo Yang.

Author
Posts
#1636399

Tell us what you are trying to do?

Hi, I have more custom fields displaying than I need on the admin side right now. I was helped before and shown how to hide select custom fields for a child post in this ticket (https://toolset.com/forums/topic/solution-for-not-using-repeating-fields-should-not-be-used-in-child-posts/). However, if possible, it would be great to also display only certain custom fields in the admin editor for the post as well (not just its child post). Is this possible?

Is there any documentation that you are following?
https://toolset.com/forums/topic/solution-for-not-using-repeating-fields-should-not-be-used-in-child-posts/

What is the link to your site?
hidden link

#1637117

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

In WordPress admin side, when you edit a parent post, in the child post type relationship section, there is a "Gear" button, see screenshot gear.JPG, with it you can select/hide specific custom fields of child post type.

#1644227

Hi, thank you for your help. When editing the parent post and scrolling to the bottom of the page, I do not see the Gear button. Am I looking in the wrong place or is there an issue with my set up?

#1645731

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As I mentioned above, it is "when you edit a parent post", for example:
Dashboard-> Your parent post-> Find and edit a post.

If you need more assistance for it, please provide a test site with the same problem, also point out the problem post URL, private message box enabled. Thanks