Skip Navigation

[Resolved] fix sluf for taxonomies archive

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 5 replies, has 2 voices.

Last updated by Waqar 1 year, 6 months ago.

Assisted by: Waqar.

Author
Posts
#2505373

this is my custom post page:
hidden link
there is a filter bar based on taxonomies
if you click on "Awards" for example, you will see this page:
hidden link
I need to remove "blog" from this slug - can you help me?

#2505909

Hi,

Thank you for contacting us and I'd be happy to assist.

Can you please go to WP Admin -> Toolset -> Taxonomies and see if /blog/ slug is added in the "Rewrite" settings of the taxonomy 'News Category'?

If you see it there, please remove it and save the settings, and then check the taxonomy archive URLs again,

I hope this helps and please let me know if you need any further assistance with this.

regards,
Waqar

#2509005
2022-12-04_09-43-45.jpg
2022-12-04_09-41-57.jpg

Hi
/blog/ wasn't there, it is empty - see attached image

I also attached the general settings, since I need the "/blog/..." in the post URL

Do you have another solution?

#2510209
post-type-front-base-settings.png

Thank you for sharing these details.

If you've set the '/blog/' in the general permalink settings, you can go to the settings of the individual custom post types and uncheck the option "Allow permalinks to be prepended with front base".
( example screenshot attached )

This will exclude the '/blog/' front base from that post type's permalink.

#2514371
image 3.jpg
image2.jpg
2022-12-13_09-48-07.jpg

Hi
my custom post type is "Success Stories" - see the settings in the attached image - the "Allow permalinks to be prepended with front base" is NOT selected. and this is fine if I go to the Success Stories page: hidden link and I click on one of the items, for example:
hidden link
this is fine, I DON"T want to see /blog/ here.

But my issue is NOT with the post type. it is with the taxonomies.
so see image 2 for the taxonomy - "Success stories categories"
I disabled the "Allow permalinks to be prepended with front base" there too.

but, on this page: hidden link where you see the list of the Success stories categories, that was made with custom menu, using the "Success stories categories" items (see image 3) , if you click on every one of them it takes you to a URL WITH /blog/ and you get 404 page.

404: hidden link
correct: hidden link

the problem here is why the menu is not working right?

#2516319

Thanks for writing back.

Looks like this was a cache issue either at the server or CDN (Cloudflare) level.

Now, when I check the category archive page links on the "Success Stories 2022" page, they're pointing to the correct URL without the '/blog/' part.

Can you please check again, after clearing the browser's cache?

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.