Skip Navigation

[Resolved] Fatal out of memory errors when trying to get to edit template page

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 23 replies, has 2 voices.

Last updated by Waqar 11 months ago.

Assigned support staff: Waqar.

Author
Posts
#2302453

Oh OK. I'll talk to the hosting provider first. More info shortly.

#2302485

Ok, my call with the host wasn't very productive in my opinion. The person I spoke to there didn't seem to understand what I was saying and wasn't really listening to me. I was able to get from her confirmation that 2048M is what was being used. She said we cannot go any higher than that on shared hosting. I'm not 100% sure that what you told me to ask her about was what she was answering there. I read to her what you said to ask about word for word, but I'm not sure she grasped the question. There was a bit of a language barrier as she spoke with a very heavy accent and didn't really listen to the specifics of what I was asking about. She spoke in very general terms.

I'm tempted to call them again to see if I can get a different representative that will listen more. But I'd say having you check it will probably lead to better results. The tech support for our hosting company has gotten progressively worse over the years and is now pretty bad. We're likely to move the site to a VPS host, but I fear that won't even solve this issue. If we were getting out of memory errors with a bunch of other things we were trying to do, I'd be more convinced that this is strictly an out of memory issue. But with it *only* happening when we try to enter your block editor, and with us having the memory set at the absurdly high 2048M level, I'm thinking something else has to be happening here. Maybe we do just need to go higher than 2048M, but that would shock me if that's the case. We will have to move to VPS hosting to do that. But I'm hoping you can look at it and find another solution.

#2302489

Let me know if you need anything further from me or if you want me to talk further with our hosting about anything.

#2304677

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Can you please share the temporary WordPress admin login details of the website again?
( as mentioned in my last reply, the access details that you shared earlier are no longer working )

This will allow me to download a clone/snapshot of your website and then test it on my server.

Note: I'm setting your next reply as private again.

#2305555

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the admin access.

I was able to download the website's clone using the Duplicator Pro plugin, currently performing some tests on it.

Will share my findings, as soon as this testing completes. Thank you for your patience.

#2306783

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for waiting.

I've tested your website's clone on my localhost server as well as an online test server, but I'm not seeing the fatal error while editing the content template. This confirms, that something specific to your current server/host is involved.

Here is a link to an online copy that you can access with the same admin access details:
hidden link
( this is a test install and will be deleted in a couple of days )

When I try to edit the content template "Template for Partners" on these clones, I'm able to edit them, but not on your actual website, where the error screen is shown.

Note: I'm still seeing the 'SCRIPT_DEBUG' constant set to 'true' in your website's 'wp-config.php', which should be set to 'false'.

#2308893

OK, I logged into your clone site and re-activated the plugins we'd prefer to have active. Then I set the default editor to be the block editor. I then created a new Posts archive from the Toolset dashboard and the block editor is loading fine with no errors. So it's definitely something with the hosting as you've indicated. I guess we will have to move to VPS hosting next to see if that gets our version working with no errors.

This also says that 2048MB for the memory limit is sufficient under your hosting though. Is that what you have it set at on your end? So I shouldn't need to increase that and it means that something else with our shared hosting is the root cause of the problem. Can you change your memory limit downward just to satisfy curiosity here? I've never had to increase the memory limit above 512MB and was shocked that I was having to keep going up with this situation. Can you change the memory limit on your end downward and check if you can create the error when trying to get into your block editor? If you can do that and determine what memory limit works and doesn't work on your hosting, that will let me know what it actually should be for us. I don't want to have to set it as 2048 MB if we don't need that much. Or is it OK to set it much higher than what you actually need? I'm thinking setting it too high might have negative consequences too, but I could be wrong there.

OK, I'll let both clients know that we have to move to VPS for this to work. You've checked this for me for this FYCCN site, but I'm also having the same thing happen with another client's site I'm also working on here.

#2308895

Thanks hugely for all the effort here. Sorry this is causing so much extra work.

#2310049

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

This online clone of your website is hosted on a very basic level server with only 1 GB of ram.

If you'll go to WP Admin -> Tools -> Site Health -> Info of this online clone, you'll see that the 'PHP memory limit' is already set to only '256M', and even still the website is not showing the same errors as your host.

This confirms that it is not just the allowed memory, but something else is involved with your current host. You can try increasing the "PHP max input variables" value to '10000' (currently '1000') and 'PHP time limit' to '300' (currently '120'), on your current server and test again. In case the issue persists, it would be best to proceed with switching to a different server/host.

The Toolset's recommended server requirements are available at:
https://toolset.com/toolset-requirements/