Skip Navigation

[Resolved] Editing Profiles redirects to Edit Layout page

This support ticket is created 2 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 4 replies, has 2 voices.

Last updated by jeffM-14 2 years, 1 month ago.

Assigned support staff: Waqar.

Author
Posts
#1870909

The editing of CAPPA Member profiles appears to be broken. I looked into it briefly today and it appears the ToolSet plugin for Layouts is not functioning as expected.

Here's what happens: Within the WP Admin, navigate to CAPPA Members, click into a profile to Edit it (for instance hidden link).

If you try to edit anything, say within the content area, the Edit page redirects to the Edit Layout page (hidden link) and you cannot edit any information for the Member.

If a Member tries to update their profile from the public side from the link within the hidden link page, when they save their edits, the display profile disappears.

You can see this on my test profile: hidden link

Nothing displays.

#1871223

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I see from your website's debug info that you have out-of-date versions of Views and Layouts.

That's understandable, as Views and Layouts have been temporarily removed from the custom Toolset installer which is being redesigned, and need to be updated manually.
( ref: https://toolset.com/errata/many-back-end-links-unexpectedly-redirecting-to-create-new-layout-with-wordpress-5-6/ )

Note: If you have problems accessing your plugins page (because of the issue described above), you may need to remove the previous version using FTP.

Once these plugins have been updated to the latest versions, please clear all involved caches and then check these edit pages.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1871757
Screen Shot 2020-12-10 at 9.17.30 AM.png
Screen Shot 2020-12-10 at 9.12.06 AM.png

Thank You for the note back. We have installed the latest available versions of the Views (3.3.4) and Layouts (2.6.7) plugins and are still having issues with trying to edit profiles and viewing a profile. I've attached two images here to show what we see. (The second photo shows an empty page where it should be showing all the fields)

#1872797

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update.

If you'll check the edit screen of the "test" CAPPA Member post, you'll see that the content template "Display CAPPA Member Profile" and the layout "Layout for CAPPA Members" both are assigned to it at the same-time, which is why it is not showing any content on the front-end.

Another CAPPA Member post "Abby Hiatt" is assigned only the content template "Display CAPPA Member Profile" and it is showing the content accordingly on the front-end.

The layout "Layout for CAPPA Members" itself is empty. If you'd like to continue using the Layouts, please add the content in this layout and then assign it to all CAPPA Member posts, without assigning any content template.

Alternatively, if you don't need the Layouts, you can adjust the content template "Display CAPPA Member Profile" as needed and then assign it to all CAPPA Member posts, without assigning any layout to them.

I hope this makes sense.

#1876531

Thank You for your help, Waqar.

So if I am understanding properly, we should no longer be using the Layouts plugin?