Skip Navigation

[Resolved] Content template -> save to draft mode will remove all templates from pages

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by keijoM 1 month, 1 week ago.

Assigned support staff: Waqar.

Author
Posts
#2429575

I am trying to: Update page. Update button does not come visible when I edit pages. After saving page content to draft update button come live again. This will cause problems, that hundreds of pages are without correct page template. System changes all templates "assigner by toolset" after i save template to draft.

How to fix this issue?

Link to a page where the issue can be seen: projecta.avosorsa.com

I expected to see: Pages with dynamic content.

Instead, I got: How to set many pages to correct template easily or how to restore situation before i saved template to draft and update it again?

#2430203

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

example-content-template-assignment.png

Hi,

Thank you for contacting us and I'd be happy to assist.

It is default or normal state, if you see the option "Template Dynamically Assigned by Toolset" selected in the "Content Template" field, on the page/post edit screen.

The assigned template is shown below the field, as can be seen in the attached example screenshot.

If you're seeing the content template in the same way, no further action is needed. However, if you continue to see some abnormality, you're welcome to share temporary admin login details, along with the exact steps to see it.

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

#2431141

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

The bulk assignment of a content template can only work if you have to assign it to all posts in a post type or to all the pages.

But, if you have to assign it to only selected posts or pages, then you'll either have to use the conditional assignment option ( ref: https://toolset.com/course-lesson/assigning-templates-to-posts-conditionally/ ) or assign it through individual post/page edit screen.

As for the main issue of why you're not able to save changes to the content template "Blocks-tuote-esite", I see a number of script errors in the browser's console. These errors can be the result of a conflict with the code from the active theme or from a third-party plugin.

To troubleshoot this, I'll suggest the following steps:

1. Please make sure that WordPress, active theme, and plugins are all updated to the latest versions.

2. It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty-One.

If it's fixed, you can start adding the disabled items, one by one, to narrow down to a possible conflicting one.

3. In case the issue still persists, I'll need your permission to download a clone/snapshot of this website to investigate this on a different server.

I hope this helps and please let me know how it goes.

#2433407

I see a number of script errors...

What is the fastest way to check errors or is there some keyword that helps me find errors?

Br. Keijo

PS. I will test what will cause this and let you know before we close this ticket.

#2434059

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

Here are some useful articles on using the browser's console to troubleshoot script errors:
https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/
hidden link

I'll wait to hear back from you about the results of those troubleshooting steps.

#2439421

My issue is resolved now. Thank you!