Skip Navigation

[Escalated to 2nd Tier] Compatibility issue between Divi and Toolset Blocks

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 3 voices.

Last updated by Minesh 4 months, 3 weeks ago.

Assigned support staff: Jamal.

Author
Posts
#2073513

There appears to be a compatibility issue with Toolset Blocks and Divi - I am testing on a staging site a copy of a client site that was functioning correctly previously with the combination of Toolset and Divi pages and posts, but now, when I try to edit posts, the Divi Builder no longer loads.

With Toolset Blocks disabled, the Divi Builder loads correctry.

Latest version of Toolset Types and Blocks installed on the site, along with the latest version of Divi.

#2073627

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I just want to let you know that the copy is still building. I first tried Duplicator, which fails. Then I installed All In One Migration and it is still building the copy. I'll let you know when it is done.

#2073799

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I took the copy and debugged it locally, but I could not find the cause of the issue. Let me escalate it to our 2nd Tier for further analysis and get back to you as soon as possible.

#2074727

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Jamal is on vacation. This is Minesh here and I'll take care of this ticket. Hope this is OK.

The thing is that as mentioned with the following errata page:
=> https://toolset.com/errata/divi-builder-fails-to-load-if-post-being-edited-has-content-template-assigned/

We’ll coordinate with Divi but recommend you report this issue to Elegant Themes support to expedite a solution.

To test this further we already went back to Toolset Blocks version 1.2 from May 2020 and Divi v4.9.2 and the problem still happens, so it surely must be because of some change in Divi.

We do already have a internal ticket for this compatibility issue but this seems to be not on us but Divi. We are waiting for reply from divi and if you get reply from divi and if they share the information that the issue is from Toolset (which looks like not the case as of now) we are happy to fix.