Skip Navigation

[Resolved] Clone View not found

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 1 reply, has 2 voices.

Last updated by Waqar 1 year, 7 months ago.

Assigned support staff: Waqar.

Author
Posts
#2013721
02.png
01 - Edit-Content-Template-‹-Porto-di-Otranto-—-WordPress.png

I am trying to: create new content templates using a clone of the first View, contextualized to the CPTs using query filter.
The Views contains the Forms for creating or edit posts about the CPTs set into the content selection.
The first clone works fine, but others return me the "View not found" when I try to reopen the content template (see the attached image). And in the front end I cannot see the Form...
Then, I delete the View that has the error message and I select a new View block and set the same View in the lists of existing Views.
Now, the View is opened, and ask me if I want to Edit the Original View or Edit a Copy, like a normal. But now, if I try to click the Edit Original View or Edit Copy the system doesn't do anything (see the attached image)... If I save the content template, now I can see the form in the front end...

But this for me is a big issue because if I would make a change in the Views I cannot edit them into content templates...

What could be the issue

Link to a page where the issue can be seen: hidden link

#2014359

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

You are experiencing difficulties in this current workflow, due to a known issue, where the duplicate of a content template that includes the Form block is not editable.

A fix for this is included in the upcoming release of Toolset Blocks/Views (1.5 / 3.5).

Until that release is out, you can try the following workaround. Once your original content template with the view is ready, you can remove the form block from it and then create its duplicates. After the duplicates are made, you can edit the views in them to include the form block.

I hope this helps and let me know how it goes.

regards,
Waqar