Skip Navigation

[Resolved] Checkbox value (checked/unchecked) not showing in Admin Dashboard

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 5.39 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by Waqar 1 month, 3 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#2187751
Unchecked checkbox in admin dashboard.png
Checkbox custom field for user registration in front end.png
Checkbox custom field for user registration form.png

Hi Team,
my checkbox value is not showing as checked/unchecked in admin dashboard. I have created a user registration form with custom fields with the help of Toolset plugin. The checkbox field is required and users always checked that field but it is always showing unchecked at admin dashboard. Please check the screenshots.
Could you please help?

#2188663

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I've performed some tests on my website with a similar checkbox type user field, but couldn't reproduce this issue.

To troubleshoot this, I'll suggest the following steps:

1. Please make sure that WordPress, active theme, and plugins are all updated to the latest versions.

2. It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty-One.

If it's fixed, you can start adding the disabled items, one by one, to narrow down to a possible conflicting one.

3. In case the issue still persists, I'll need to see how this field and the form are set up in the admin area. You're welcome to share temporary admin login details, along with the link to the form page.

Note: Your next reply will be private and it is recommended to make a complete backup copy, before sharing the access details.

regards,
Waqar

#2190599

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

During troubleshooting, I noticed that in your custom code snippet, there is a code that checks for the value of the field with the slug "user-acceptance". But the checkbox field that you're using has the field slug "terms_conditions_agreement".

As a result, the value for the non-existent field "user-acceptance" is always empty, and the form always shows the message "Please accept our terms and conditions before submitting the form".

You'll find the code at WP Admin -> Snippets -> All Snippets and in the snippet named "User role update based on mail domain".
( line# 148 - screenshot: hidden link )

Please update the correct field slug in the code and the form submission will be fixed.