Skip Navigation

[Resolved] changing slug dog-walker by another word

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 8 replies, has 2 voices.

Last updated by Waqar 3 months, 2 weeks ago.

Assisted by: Waqar.

Author
Posts
#2634029

Hello,
I would like to use the dog-walker template, it suits my needs perfectly, I would just like to change the slug from 'dog-walker' to 'directory'.
I changed it directly by editing the post-type, but the items are no longer displayed.
is there a procedure, even in sql, to do this and keep all the demo content?
Thanks for your help

#2634261

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

> I changed it directly by editing the post-type, but the items are no longer displayed.

- If a custom post type's slug is updated from the settings ( WP Admin -> Toolset -> Post Types ), it automatically updates it for the existing posts in that post type.

Can you please share some details about the exact steps that you took to change it and then where the demo content items are not showing?

I'll be in a better position to suggest the next steps, accordingly.

regards,
Waqar

#2634429
error-admin.png

Hello,
I modified the slug exactly this way.
But published articles no longer appear in the admin as you can see on the image.
However, if I create a new article, it appears.
thanks for the help

#2634463

For following:

I've deactivated WPML and the articles do appear in the admin now, but still not on the home page.
After checking, the WPML tables don't update when the slug is changed.

Is there a solution? Or do I have to go back to the demo version without WPML?
Thanks

#2634473

For following:
I installed the version without WPML, the articles appear well in the admin but not on the homepage, once the slug modified.
The "All" button always returns to */dog-walker/

#2634621

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these updates.

Can you please share temporary admin login details, so that I can see how the homepage and the WPML are set up in the admin area?

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

#2634997

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Thierry,

I'm getting the 'incorrect password' message.

Can you please check the username and password again?

I'm setting your next reply as private.

regards,
Waqar

#2635723

Hello,
Some news?
Thanks

#2635935

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the access details.

During troubleshooting, I noticed that the post slugs were correctly updated, but the language information from WPML was not correctly assigned to the existing posts.

I used the 'Set language information' button from the WPML troubleshooting page ( WP Admin -> WPML -> Support -> Troubleshooting ) and it fixed the issue of the existing 'Annuaires' posts not showing in the admin area.

As for the homepage views, the view settings were there, but since the post type was changed it needed to be selected again from the view block's 'Content Selection' tab.
( screenshot: hidden link )

I've selected the updated post type for both the views used on the homepage and the posts are showing now.

I hope this helps and please let me know if you need further assistance.

#2637171

Hi,
Everything is working fine, thank you for your help

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.