Skip Navigation

[Resolved] Cannot edit non-Toolset Pages – "Layout for Pages" screen dominates everything

This support ticket is created 2 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 2 replies, has 2 voices.

Last updated by Patricia Ayers 2 years, 1 month ago.

Assigned support staff: Waqar.

Author
Posts
#1870963
screenshot-Layout-for-Pages.png

On both my sites which use Toolset plugins, after updating to WP 5.6, I am trying to edit NON-TOOLSET Pages.

These are Pages made with the Classic Editor plugin, not Gutenberg.

Link to a page where the issue can be seen: It's on the back end.

I expected to: Edit pages normally.

Instead, I got: a Toolset "Layout for Pages" screen which would not allow me to do anything else. Even using the WP Admin menu, every click simply opens a new instance of the "Layout for Pages" screen. I'm attaching a screenshot.

This is happening *only* on sites using Toolset, only after updating WP to 5.6.

Needing to edit a Page, the only workaround I found was to disable the "Toolset Layouts" plugin, do my Page editing, and then re-activate "Toolset Layouts".

Please advise. Thank you very much in advance.

#1871221

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I see from your website's debug info that you have out-of-date versions of Views and Layouts.

That's understandable, as Views and Layouts have been temporarily removed from the custom Toolset installer which is being redesigned, and need to be updated manually.
( ref: https://toolset.com/errata/many-back-end-links-unexpectedly-redirecting-to-create-new-layout-with-wordpress-5-6/ )

Note: If you have problems accessing your plugins page (because of the issue described above), you may need to remove the previous version using FTP.

Once these plugins have been updated to the latest versions, please clear all involved caches and then check the admin area edit pages.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1874393

My issue is resolved now. Thank you!