Skip Navigation

[Resolved] Calendar reacting wrong when choosing date

This thread is resolved. Here is a description of the problem and solution.

Problem:

I have a calendar function. But when i choose a date the page reacts wrong and the area with the calendar gets way too big

Solution:

It is a CSS issue, your theme is changing the image width with CSS codes, you can fix it by CSS codes, for example:

https://toolset.com/forums/topic/calendar-reacting-wrong-when-choosing-date/#post-1966277

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 7.54 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by maiS 1 month, 2 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#1966027

Hi there,
on my site: hidden link
I have a calendar function. But when i choose a date the page reacts wrong and the area with the calendar gets way too big. Can you help?

#1966277

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

image-width.JPG

Hello,

Thanks for the details, it is a CSS issue, your theme is changing the image width with CSS codes, you can fix it by CSS codes, for example:

img.wpv-date-front-end-clear {
    width: auto !important;
}

See my screenshot: image-width.JPG

#1966797

Hi there,

Thank you so much - where do i put the CSS code?

#1967543

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

view-css.JPG

I have done below modifications in your website.
Edit page:
hidden link
find and select view block, in section "Custom JS and CSS", add the same CSS codes I mentioned above:

img.wpv-date-front-end-clear {
    width: auto !important;
}

See my screenshot view-css.JPG

Please test again, check if it is fixed.

#1969045

Hi Luo,

So the calendar is fixed but now the search results show up right under the search form. I only want the search form on this page and then the search results here:

hidden link

I don't know why, but every time people edit in this view this setting is being changed automatically.

#1969051

I removed the view and added it again and the calendar still works! thanks

#1969053

My issue is resolved now. Thank you!