Skip Navigation

[Resolved] Caching of several views not working although activated

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by ralphN-2 2 months ago.

Assigned support staff: Waqar.

Screenshot at Jun 07 21-47-25.png

Tell us what you are trying to do?
I want to set all Views to caching-enabled by default.

For all views that are created within a page (e.g. all views on page 'Home'), I have set the caching-switch to 'enabled'.
For several manually created sidebar widget views (created using the Toolset view editor in the Toolset menu) I did not see any option/switch to turn caching on/off.

Anyhow, only one of all the views appears to be cached, while all others aren't. Screenshot attached.
I'm looking for help to get this fixed.




Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ralph,

Thank you for contacting us and I'd be happy to assist.

The way the built-in cache feature works for views, you can force it in two ways:

a). In a view created using the Blocks editor, you'll find a "Cache View" option under the main "View" block's settings.
( as you noted )

b). For a view created using the classic/legacy views editor, you can force cache through cached="force" attribute in the views shortcode.

[wpv-view name="slug-of-view" cached="force"]

It is important to note however that there are certain conditions, which will force the view to not use the cached version:

- if the view is using front-end sorting controls
- If the view contains a query filter that listens to the URL parameter
- if the view contains a nested view or a content template
- if the view is set to show posts in a random order
- if the view contains the "conditional" block

I hope this information helps and please let me know if you need any further assistance around this.



Thank you Waqar, the very last bullet explains it: I am using conditional blocks in most of my views. Best regards, Ralph