Skip Navigation

[Resolved] Amir asked me to post a video of a gallery loading on block editor page

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Stephen Vaughan 7 months, 1 week ago.

Assigned support staff: Waqar.

Author
Posts
#1426149

Blocks Feedback

Hi all,

I have been testing out the blocks on one of the reference sites and notice on un-cached load of a page that the gallery takes a little while to render to the specified columns. It looks a bit clunky and on cached reload it isn't noticeable. But, first impressions do count with respect to new site visitors.

My comment on the blog post:
https://toolset.com/2019/12/learn-how-to-build-templates-archives-and-views-with-blocks/#div-comment-478395

The upload option below seems to be just for images so you will need to find a way for me to send the clip.

#1427457

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

Thank you for contacting us and for sharing your feedback.

To send a video/screencast, you can upload it to any file sharing service (like Google Drive, Dropbox, OneDrive, etc) and then share its link in the ticket.

Note: Some customers also prefer direct screen capture and share service like "loom".
hidden link

I hope this helps and I'll wait to hear back from you.

regards,
Waqar

#1427623

Hi Waqar,

Here is a link on DropBox to the video clip:

hidden link

#1431083

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

Thank you for sharing the screencast and Amir has already sent it to the concerned team.

I'll keep you updated with the progress through this ticket and appreciate you've brought this forward.

regards,
Waqar

#1435927

Christian
Supporter

Hi Stephen,

I'm Christian, one of the developers of Toolset Blocks.

I totally agree with you that it look really odd for new visitors to first have the unordered list dots in the place of the gallery. Seems some CSS is loaded too late.

We will fix this asap and it should be shipped with the next week update of Toolset Blocks.

Thank you,
Christian

#1443773

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

I'd like to update that an improvement to the gallery block's loading is planned to be covered in the upcoming Blocks release.
(version 1.0.2)

Thank you for the feedback.

regards,
Waqar

#1444011

Thanks for the update. You mention the Blocks plugin. Will the same apply to Views as well? I would be using Views as I rely on more than just the blocks aspect of what Views does.

#1444017

I noticed the issue on the Gym reference site and that probably used the blocks plugin. The same issue may not effect the Views plugin.

#1445833

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

The changes/improvements to any Toolset block will apply across both plugins (Views and Blocks).

And as our reference websites also use our standard Toolset plugins, the gallery loading will automatically improve, once this release is out and the plugins are updated.

I hope this clarifies.

#1448099

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

The latest releases of Toolset Blocks (1.0.2) and Views (3.0.2), both include improvement for this gallery block's loading.

You're welcome to try it and let us know if you have any follow-up feedback or comments.

Thank you for your time and input.

regards,
Waqar

#1449041

Hi Waqar,
I checked on the Gym reference site. All looks good. Thumbs up!