Skip Navigation

Ajax on filter change doesn't load anymore

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Luo Yang 1 year, 2 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#2125893

I have this dev site with a view here... hidden link user:flywheel pass: caffinated-support the view is only showing 1 category of products, so there are 255 products, that are returned by the view to be filtered. When I set it to ajax filter on change it just spins and gets stuck accessing admin-ajax.php If I use page refresh on submit it works fine, just a performance issue with the ajax.... Now I would be happy with the refresh, if I was able to have the refresh happen automatically on filter change. That is how hidden link WOOF does it and it works quite well. so if my ajax isn't fixable and it's a limitation, then is there anyway to make the submit happen on filter change automatically using JS or something?? using a submit button doesn't work well at all with my design as people wouldn't know why it's not changing.

in a some what unrelated question... will you guys ever use the rest api and not admin-ajax.php ??

#2126159

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Yes, you are right, the Views AJAX feature is based on WordPress admin-ajax.php, and there isn't any plan to switch to REST API.

I have checked the URL you mentioned above, I can only see a htaccess login window.

And the problem you mentioned above is abnormal, there should be some JS/PHP errors in your website:
check if there is any PHP/JS error in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

#2126913

I provided the user name and password to access the sites front end, here is it AGAIN:

user:flywheel
pass: caffinated-support

I have no js errors, or anything but I will turn on the views debugging now.

#2127155

Is it likely to be caused by this message? looks like the WP scheduler is having issues, So I'm opening a ticket with my host. do you know if this would effect the toolset sorting.

"WooCommerce is updating product data in the background
Product display, sorting, and reports may not be accurate until this finishes. It will take a few minutes and this notice will disappear when complete. "

#2127163

Ohh nope that does not look like the issue, you can also see the same broken filter on the "live" site and that one does NOT have the scheduled tasks issues 🙁 so back to you. I can provide access to the backend of the dev site if you like.

#2127167

oops I didn't have the latest release! it fixed me up, sorry for that one.

#2127491

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

ajax.JPG

I have tried it in your website, it works fine, see my screenshot ajax.JPG

Is this issue resolved? please let me know if you need more assistance for it. thanks