Skip Navigation

[Resolved] Yutube display in toolset

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+01:00)

This topic contains 5 replies, has 2 voices.

Last updated by Nigel 6 months ago.

Assisted by: Nigel.

Author
Posts
#2653529
error.jpg

Dear support team,

The toolset training sysytem "Paint your world" is being taught.
A yutube has been set up on the site's contribution blog. The yutube is displayed successfully. The yutube does not appear correctly on my blog, which I created according to the site. See attachment.
I am sorry, but I need your support.

Regards,

Yoshihiko

#2653573

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Yoshihiko

From your screenshot it looks like you have added a youtube URL to a custom field on your post, but the video is not being displayed when viewing the post on the front end, correct?

Can you confirm what type of custom field you are using?

And, you have created a Content Template for the posts you are showing, yes? Did you use a Youtube block to output the video?

For us to see why it is not working it would help if we could check the back end of your site to see how you have this set up.

Let me mark your next reply as private so that we can get log-in credentials from you—you may want to create a temporary admin user for us to use that you can later delete. And be sure to have a current backup of your site.

Can you also confirm what post we should check to see the problem?

#2653659

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Screenshot 2023-10-17 at 11.07.54.png

Thank you for that, but unfortunately it seems that you have some security blocking access to the site (screenshot).

If that is related to the location of my IP address, I am in Ireland.

Could you make whatever security changes are needed and let me know when I can try again?

#2653693

Dear nigel,

I apologise to you for my inadequacies.
I have now deactivated each security setting on WordPress.
I am very sorry and I ask you to access it again.

Regards,

Yoshihiko

#2653775

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

That is rather odd. Everything looks to be set up correctly, but it isn't working—even when I disable non-Toolset plugins and switch theme to rule out any possible code conflicts.

To debug the issue I need to do that on a locally-installed copy of the site, so I will set that up and try and identify the cause.

I'll get back to you with my findings.

#2654401

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Thanks for your patience.

I found the problem, which seems to occur because of the use of non-Latin characters for the name of the custom field group.

You had called the field group "Field Group for 投稿", and this broke the dynamic source code where you specified the source of the video in the content template.

I changed the name of the field group to "Field Group for Posts", edited the template and re-set the source of the youtube block, and now it works.

I will look into this further and report it to the developers, it should be possible to use other character sets for field group names.

But in the meantime I suggest you avoid using them and limit yourself to latin characters for now.

yoshihikoH confirmed that the issue was resolved on 2023-10-19 10:56:48.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.