Skip Navigation

[Closed] wp_toolset_maps_address_cache is corrupted and prevents database import

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 3 replies, has 2 voices.

Last updated by Luo Yang 6 months, 1 week ago.

Assigned support staff: Luo Yang.

Author
Posts
#2369711
Screen Shot 2022-05-23 at 2.57.12 PM.png

I had a strange problem trying to migrate the wordpress MySQL database from our live site to our staging server. When I tried to import the database via the command line, I got the following unusual error which caused the mysql import to fail:

ERROR 1416 (22003) at line 2673: Cannot get geometry object from data you send to the GEOMETRY field

The culprit appears to be that our 'wp_toolset_maps_address_cache table' contained a number of rows with a NULL (or blank) value for the 'point' column, which uses the special POINT MySQL type.

When I manually deleted those rows and re-exported the database, I was then able to successfully import our database.

I'm sending this as a bug report, because I can't think of any good reason for toolset to be inserting invalid (blank) POINT records in this table -- especially since at least some versions of MySQL have a hard failure trying to import a database containing such rows.

#2369843

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Please try these:
Before you migrate the data, Go to the original website:
Dashboard-> Toolset-> Settings-> Maps,
In section "Cached data", click button "Check for missing cache entries", this should be able to fix those "Null" value items.

More help:
https://toolset.com/course-lesson/data-caching-for-maps-addresses/

#2370005

Hello,

If this isn't a bug, what is the purpose of having blank/null entries in this table like those in my screenshot?

What I am looking for here is an acknowledgement that this is a bug that will be fixed at some point. I already have a work-around that works very well: I just open the database and delete the blank entries. I took the time to report and document this bug because I love Toolset and I like to see it succeed -- not because I need some different work-around.

#2370405

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

map-cache.jpg

Please provide detail steps to reproduce the same problem, I have tried it in my localhost with a fresh WP installation + the latest version of Toolset plugins, use the same address value as your screenshot: Tucson, AZ, USA
It works fine, I can see the cached value in Maps setting page, see my screenshot

The topic ‘[Closed] wp_toolset_maps_address_cache is corrupted and prevents database import’ is closed to new replies.