Skip Navigation

[Resolved] Warning notice Cause by Toolset Form Commerce 2

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by wilfredC 2 months, 1 week ago.

Assigned support staff: Waqar.

Author
Posts
#2417341

Hi, this ticket is related to my previous solved ticket
https://toolset.com/forums/topic/warning-notice-cause-by-toolset-form-commerce/

I thought the problem is solved but then after a new order it got the warning notice again

"Warning: Trying to access array offset on value of type null in /var/www/vhosts/wxxxxxxxx/wp-content/plugins/cred-commerce/classes/CRED_Commerce.php on line 886"

I tried to changed the theme, and deactivated all plugin except toolset plugins and woocommerce plugin, but the warning error still show on the checkout page and thank you page

#2417517

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I've performed some tests on my website and was able to reproduce the warning notices on the checkout and the order thank you pages. These notices are shown when the product is added to the cart, without the Toolset Form and the 'Toolset Forms Commerce' plugin is also active.

Thank you for bringing this forward and I've shared these findings with the concerned team for further review. Because the fix for these notices is fairly simple, most likely it will be included in the next release of the 'Toolset Forms Commerce' plugin and we may also have a patch to share with you, before the release.

I'll keep you updated, through this ticket.

regards,
Waqar

#2417531

Noted.

And may I know when can get the issue solved? Cause I need to inform this issue to my client.

#2417673

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back and I've got the confirmation that this notice will be fixed in the next release of the 'Toolset Forms Commerce' plugin.

Although, I don't have a time estimate for the release, here is a patch file that you can download and use meanwhile:
hidden link

In this zip file, you'll find a file named "CRED_Commerce.php" and you can replace it with a file of the same name in the folder at: /wp-content/plugins/cred-commerce/classes/

#2419219

My issue is resolved now. Thank you!