[Resolved] Views conflict with Elementor Pro

This thread is resolved. Here is a description of the problem and solution.

Problem: When having Toolset Views active and Elementor Pro we cannot edit a post with Elementor on the front end. It says it must have `the_content()` enabled on the post to work fine. As soon we disable the Views plugin this is solved.

Solution: Most certainly you have assigned a content template to a post, and then edit that post with Elementor. That's not possible. You should instead create templates or post designs with Elementor, and in those, insert Content Templates if required using Elementor widgets for Content Templates.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Beda 2 months ago.

Assigned support staff: Beda.

Author
Posts
#1485947

When trying to edit a post using Elementor I get an error about the_content being required.

I have only Elementor, Elementor Pro and Views plugins installed and using Twenty Nineteen theme.

To recreate error, create a new post. Editing old ones seems to work okay.

#1486155

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Since Elementor is throwing errors - can you try to see if they are solved or persist when you disable Toolset for a moment and try again?
If then the issues are still present, it should be reported to Elementor.

If not, then it means some conflict arises with Toolset and Elementor, but I am not aware, and could not replicate any issue that lets me see an error saying "the_content is required".

What are the precise steps to this issue, using Toolset and Elementor?
I could not see the problem on the site either, where I created hidden link as a test post.
I can also edit it.

Please let me know if I miss something in the steps so we can investigate again!

#1486339

Hi Beda,

Thanks for your assistance mate.

This issue occurs when trying to use the Elementor Editor. If you use that link and then click the Edit with Elementor button then you will see the error.

Deactivating Toolset resolves the issue.

#1486363

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

OK, I can see that - it says:
You must call 'the_content' function in the current template, in order for Elementor to work on this page.

So the_content is not present on this post, which is the native Post type Posts.
The issue indeed is solved when disabling Views on your site.

That's due to your Content Template you have assigned to all Posts by type.
It's here:
hidden link

You've set this to apply to all posts, so all new posts will use this.
But you can't assign a Content Template when styling with Elementor, see this:
https://toolset.com/documentation/user-guides/using-toolset-with-elementor-page-builder/

You'd rather style posts or elementor templates with elementor and in there, use Content Template Widgets, of Elementor, if required.

#1488169

Thanks Beda! Is that default content template from a newer version?

#1488231

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

You must have created it, or another Administrator, if there is anyone else on the site that has access to create or edit Custom Content Templates.

Toolset does not create content or structures "automatically".