Skip Navigation

[Resolved] View search filters don't work until after pagination

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 3 replies, has 2 voices.

Last updated by David 1 year, 2 months ago.

Assisted by: Waqar.

Author
Posts
#2511653

I have a custom post type view with some taxonomy search filters.

Now, the filters don't work until the results are paginated. The filters are displayed, but there are no selectable options until the second page.

I am using an "AND" query for my multiple taxonomies.

To see the problem, visit hidden link and try to use the search filters.
Then, scroll to bottom of page and press the "More" button. Then try the filters again - they should work then.

I have tried recreating a new view the same, but the same problem occurs again.

I tried removing pagination, but then the filters also did not work.

#2512339

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I noticed a number of script errors in the browser's console when that page is viewed.
( they are related to the multiple property codes included for the AdSense tag and from an external script file hidden link )

To troubleshoot this, I'll suggest the following steps:

1. Please make sure that WordPress, active theme, and plugins are all updated to the latest versions.

2. It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty-One.

If it's fixed, you can start adding the disabled items, one by one, to narrow down to a possible conflicting one.

3. In case the issue still persists, I'll need your permission to download a clone/snapshot of your website, to investigate this on a different server.

I hope this helps and let me know how it goes.

regards,
Waqar

#2512367

Hi Waqar,

Many thanks for taking a look at this for me. It's really puzzling.

A similar view works fine (actually the taxonomy archives, eg. hidden link); it's just on this page, and it was working before.

I have tested with other plugins deactivated and the default theme. Still there is the problem.

I have now identified that the most recent post is the cause of the problem, though I don't know why. I've currently set that as a Draft and now the filters work.

If you could clone the site and download it for me, that would be fantastic. I give you persmission to do that.

#2512487

Thanks

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.