Skip Navigation

[Resolved] Unformated Loop keeps looping db records while editing the View, see screenshots

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Christian Cox 3 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#2118087
View 3.jpg
View 2.jpg
View 1.jpg

Tell us what you are trying to do? Setting up unformatted loop w search function to select and present selected records from db, screenshots taken with short intervals. And yes, I have tried w/o any plug inns but Toolset!

Is there any documentation that you are following? Toolset doc

Is there a similar example that we can see? This view I got working despite the problem: hidden link

What is the link to your site?hidden link

Any suggestions? The WP editor is a buggy beast anyway but this makes it even worse 🙂

#2118133

Hello, if I understand what you are saying, it seems the View editor is constantly updating in wp-admin when you edit this post or template. Is that correct? May I log in and see the problem? Please provide logins in the private fields here so I can take a closer look.

#2119051

I don't see anything obviously wrong in the setups of these Views that would be causing this constant update behavior in the editor. Can I try these troubleshooting steps?
- You mentioned you had tested with only Toolset plugins active and the problem was not resolved. Is it okay for me try this as well to compare the behavior with and without other components active?
- Is it okay for me to uninstall the Toolset plugins and reinstall fresh copies if necessary?
- I'd like to see if there are any server-side errors logged in the server logs. If you are familiar with server logs, please activate logs and reload the editor page where the problem occurs. If any server-side errors are generated, please copy + paste those into your next reply. If you are not familiar with server logs, I can set one up temporarily by adjusting your wp-config.php file if you provide FTP access here.
- Is it okay for me to create a Draft Page and create a test View to see if the problem can be reproduced in a View with different configurations? For example, to create a view of another post type, or a View with different sorting and pagination options.

#2119145
Error log SiteGround.jpg

Dear Christian, good in a way, I am not an experienced user so mishaps might always be caused by me doing something obvious wrong. To answer your questions: Yes, pls feel free to switch off plug inns. no worries. The whole site is under development , no users yet. Yes, you can reinstall Toolset, no problem. Draft page: of course, feel free to set up new pages/views the existing databases. Objects is the one that seems to give the problem.
Server log: NOT familiar so might need some manual or handholding. But when I looked under Error log on SiteGround (my host) I only found this :
2021-07-19 15:29:07 UTC [apache][:notice] [pid 82660] [client 51.146.199.62:39434] mod_hive matched URI hidden link (/home/u858-ksmgjdvtuto0/www/ridgetopresources.com/public_html/wp-login.php) with match 2, referer: hidden link
I enclose a screenshot from the page I found this. Yell when you need any more info, I am curious!! Thanks, Rudolph

#2119419

I don't think this error message is relevant to the problem here. I was able to trace the problem to the Ordering settings. Both of these Views were configured to sort primarily by the sequence custom field, with no secondary sorting applied. I added a secondary sort based on post date, and the Views began to calm down in the editor. Not exactly sure why this would be a problem, so I tried setting up a similar test View in my local environment. I've tried to recreate the problem myself but have not had any luck so far. There must be something I'm missing in my local test. I thought maybe it was because the first page of results all has a sequence number of 0, but that doesn't change the behavior in my local either. My shift is ending so I'll need to pick this up again tomorrow. I may need to create a clone of your site so I can present the problem to my 2nd tier support team for additional investigation. I'll give you an update in the morning.

#2120313

Hi Christian, I think you got to the right idea: I started a test page (slug = test) and all was fine until I added sorting. I added a sort field that for most records has a value between 1 and 9, so many records share the same number. It immediately started looping. I then added a Secondary sort (post date) and the looping stopped.
So I now know how to stop the looping while editing and can always add the correct sorting for that view as the last step, or while editing add a secondary sort that differentiates between results.
Big thanks for your help, I can totally live with the "feature" now I know it is not me being stupid/inexperienced but the software that does not like a sort with many equal results while editing.
Great support as always,
Kind regards,
Rudolph

#2120315

My issue is resolved now. Thank you!

#2120347

Unfortunately I wasn't able to determine the source of the problem, and I wasn't able to replicate the problem in a site created from scratch. So I did create a site clone as I mentioned, and I am escalating that problem to my 2nd tier support team for additional investigation. Luckily it does seem that adding secondary sorting to either View has provided a workaround that will allow you to continue development while we investigate. I'll keep you posted here as I receive additional information.

#2120349

Oh, I had started typing my response message and didn't realize you had already resolved the ticket. I appreciate the update and if anything changes here I'll update the ticket in the future. Thanks!